]> git.pld-linux.org Git - packages/perl-Socket6.git/blob - perl-Socket6.spec
4cc52be883eec29fe8a25bb8a0f1679fce3d29a3
[packages/perl-Socket6.git] / perl-Socket6.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Socket6
7 %define         pnam    Socket6
8 Summary:        Socket6 Perl module - IPv6-related part of the C socket.h defines and structure manipulators
9 Summary(pl.UTF-8):      Moduł Perla Socket6 - definicje i operacje na strukturach socket.h związanych z IPv6
10 Name:           perl-Socket6
11 Version:        0.28
12 Release:        2
13 License:        BSD-like
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Socket6/%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa8489135a3dbcec6233396e1aeb043b
17 URL:            http://search.cpan.org/dist/Socket6/
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Socket6 module provides glue routines to the various IPv6
24 functions.
25
26 %description -l pl.UTF-8
27 Moduł Socket6 udostępnia perlowy interfejs do różnych funkcji IPv6.
28
29 %prep
30 %setup -q -n %{pnam}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make}
36 pod2man --section=3pm Socket6.pm >Socket6.3pm
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d $RPM_BUILD_ROOT%{_mandir}/man3
43
44 %{__make} install \
45         DESTDIR=$RPM_BUILD_ROOT
46 install Socket6.3pm $RPM_BUILD_ROOT%{_mandir}/man3
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc ChangeLog README
54 %{perl_vendorarch}/Socket6.pm
55 %dir %{perl_vendorarch}/auto/Socket6
56 %attr(755,root,root) %{perl_vendorarch}/auto/Socket6/Socket6.so
57 %{_mandir}/man3/Socket6.3pm*
This page took 0.034612 seconds and 3 git commands to generate.