]> git.pld-linux.org Git - packages/perl-Signal-Mask.git/blob - perl-Signal-Mask.spec
- package owned directory
[packages/perl-Signal-Mask.git] / perl-Signal-Mask.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Signal
6 %define         pnam    Mask
7 Summary:        Signal::Mask - Signal masks made easy
8 Name:           perl-Signal-Mask
9 Version:        0.008
10 Release:        2
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Signal/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  1cd1832d50e76931b69db3452e728c64
16 URL:            https://metacpan.org/release/Signal-Mask
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-IPC-Signal
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Signal::Mask is an abstraction around your process or thread signal
28 mask. It is used to fetch and/or change the signal mask of the calling
29 process or thread. The signal mask is the set of signals whose
30 delivery is currently blocked for the caller. It is available as the
31 global hash %Signal::Mask.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes INSTALL README
55 %dir %{perl_vendorlib}/Signal
56 %{perl_vendorlib}/Signal/*.pm
57 %{_mandir}/man3/*
This page took 0.099928 seconds and 4 git commands to generate.