]> git.pld-linux.org Git - packages/perl-Sereal-Encoder.git/blob - perl-Sereal-Encoder.spec
10a164e5ca34e9e96a5c81a26e4ecc681bc29bf6
[packages/perl-Sereal-Encoder.git] / perl-Sereal-Encoder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Sereal
6 %define         pnam    Encoder
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sereal::Encoder - Fast, compact, powerful binary serialization
9 Name:           perl-Sereal-Encoder
10 Version:        3.002
11 Release:        3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Encoder-%{version}.tar.gz
16 # Source0-md5:  18e88a20ae5842f98e2874557d8d525c
17 URL:            http://search.cpan.org/dist/Sereal-Encoder/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl(Sereal::Decoder) >= 3.00
22 BuildRequires:  perl-Test-LongString
23 BuildRequires:  perl-Test-Warn
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This library implements an efficient, compact-output, and feature-rich
29 serializer using a binary protocol called Sereal. Its sister module
30 Sereal::Decoder implements a decoder for this format. The two are
31 released separately to allow for independent and safer upgrading. If
32 you care greatly about performance, consider reading the
33 Sereal::Performance documentation after finishing this document.
34
35 The Sereal protocol version emitted by this encoder implementation is
36 currently protocol version 3 by default.
37
38 The protocol specification and many other bits of documentation can be
39 found in the github repository. Right now, the specification is at
40 https://github.com/Sereal/Sereal/blob/master/sereal_spec.pod, there is
41 a discussion of the design objectives in
42 https://github.com/Sereal/Sereal/blob/master/README.pod, and the
43 output of our benchmarks can be seen at
44 https://github.com/Sereal/Sereal/wiki/Sereal-Comparison-Graphs. For
45 more information on getting the best performance out of Sereal, have a
46 look at the /"PERFORMANCE" section below.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes
71 %dir %{perl_vendorarch}/Sereal
72 %{perl_vendorarch}/Sereal/*.pm
73 %dir %{perl_vendorarch}/Sereal/Encoder
74 %{perl_vendorarch}/Sereal/Encoder/*.pm
75 %dir %{perl_vendorarch}/auto/Sereal
76 %dir %{perl_vendorarch}/auto/Sereal/Encoder
77 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Encoder/*.so
78 %{_mandir}/man3/*
This page took 0.061523 seconds and 2 git commands to generate.