]> git.pld-linux.org Git - packages/perl-Sereal-Encoder.git/blob - perl-Sereal-Encoder.spec
- rebuild with perl 5.30.0
[packages/perl-Sereal-Encoder.git] / perl-Sereal-Encoder.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Sereal
6 %define         pnam    Encoder
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sereal::Encoder - Fast, compact, powerful binary serialization
9 Summary(pl.UTF-8):      Sereal::Encoder - szybka, zwarta, potężna serializacja binarna
10 Name:           perl-Sereal-Encoder
11 Version:        4.005
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/Y/YV/YVES/Sereal-Encoder-%{version}.tar.gz
17 # Source0-md5:  5af0152a2c7f13e7ae1d23952a55dd03
18 URL:            http://search.cpan.org/dist/Sereal-Encoder/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Sereal-Decoder >= 3.00
23 BuildRequires:  perl-Test-LongString
24 BuildRequires:  perl-Test-Warn
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This library implements an efficient, compact-output, and feature-rich
30 serializer using a binary protocol called Sereal. Its sister module
31 Sereal::Decoder implements a decoder for this format. The two are
32 released separately to allow for independent and safer upgrading. If
33 you care greatly about performance, consider reading the
34 Sereal::Performance documentation.
35
36 The Sereal protocol version emitted by this encoder implementation is
37 currently protocol version 3 by default.
38
39 The protocol specification and many other bits of documentation can be
40 found in the github repository at <https://github.com/Sereal/Sereal>.
41
42 %description -l pl.UTF-8
43 Ten moduł implementuje wydajny, mający zwarte wyjście i wiele
44 możliwości, serializer wykorzystujący binary protokół o nazwie Sereal.
45 Siostrzany moduł Sereal::Decoder implementuje dekoder dla tego
46 formatu. Moduły wydawane są osobno, aby umożliwić niezależne i
47 bezpieczniejsze aktualizacje. Informacje na temat wydajności można
48 znaleźć w dokumentacji Sereal::Performance.
49
50 Ta implementacja kodera domyślnie produkuje wyjście zgodne z
51 protokołem Sereal w wersji 3.
52
53 Specyfikację protokołu i inną dokumentację można znaleźć w
54 repozytorium github <https://github.com/Sereal/Sereal>.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 %build
60 %{__perl} Makefile.PL \
61         INSTALLDIRS=vendor
62 %{__make} -j1 \
63         CC="%{__cc}" \
64         OPTIMIZE="%{rpmcflags}"
65
66 %{?with_tests:%{__make} test}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 %{__make} pure_install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc Changes
79 %dir %{perl_vendorarch}/Sereal
80 %{perl_vendorarch}/Sereal/Encoder.pm
81 %dir %{perl_vendorarch}/Sereal/Encoder
82 %{perl_vendorarch}/Sereal/Encoder/*.pm
83 %dir %{perl_vendorarch}/auto/Sereal
84 %dir %{perl_vendorarch}/auto/Sereal/Encoder
85 %attr(755,root,root) %{perl_vendorarch}/auto/Sereal/Encoder/Encoder.so
86 %{_mandir}/man3/Sereal::Encoder.3pm*
This page took 0.118814 seconds and 3 git commands to generate.