]> git.pld-linux.org Git - packages/perl-Search-Xapian.git/blob - perl-Search-Xapian.spec
- added missing %dirs in %files section
[packages/perl-Search-Xapian.git] / perl-Search-Xapian.spec
1 %include        /usr/lib/rpm/macros.perl
2 %define         pdir    Search
3 %define         pnam    Xapian
4 %define         basever 1.0.16
5 Summary:        Search::Xapian - Perl XS frontend to the Xapian C++ search library
6 Name:           perl-Search-Xapian
7 Version:        %{basever}.0
8 Release:        2
9 # same as perl
10 License:        GPL v1+ or Artistic
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-module/Search/%{pdir}-%{pnam}-%{version}.tar.gz
13 # Source0-md5:  732c23816cdb79f66ed83a3c25e8975f
14 URL:            http://search.cpan.org/dist/Search-Xapian/
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  xapian-core-devel = %{basever}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module wraps most methods of most Xapian classes. The missing
23 classes and methods should be added in the future. It also provides a
24 simplified, more 'perlish' interface to some common operations, as
25 demonstrated above.
26
27 %prep
28 %setup -q -n %{pdir}-%{pnam}-%{version}
29
30 %build
31 %{__perl} Makefile.PL \
32         INSTALLDIRS=vendor
33
34 # NOTE: (this) Perl build system doesn't have CXX, but CC is used
35 %{__make} \
36         CC="%{__cxx}" \
37         OPTIMIZE="%{rpmcxxflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %dir %{perl_vendorarch}/Search
57 %{perl_vendorarch}/Search/*.pm
58 %dir %{perl_vendorarch}/Search/Xapian
59 %{perl_vendorarch}/Search/Xapian/*.pm
60 %dir %{perl_vendorarch}/Search/Xapian/MSet
61 %{perl_vendorarch}/Search/Xapian/MSet/Tied.pm
62 %dir %{perl_vendorarch}/auto/Search
63 %dir %{perl_vendorarch}/auto/Search/Xapian
64 %{perl_vendorarch}/auto/Search/Xapian/*.bs
65 %attr(755,root,root) %{perl_vendorarch}/auto/Search/Xapian/*.so
66
67 %{_mandir}/man3/Search::Xapian*
68
69 %{_examplesdir}/%{name}-%{version}
This page took 0.048703 seconds and 3 git commands to generate.