]> git.pld-linux.org Git - packages/perl-SQL-Translator.git/blob - perl-SQL-Translator.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-SQL-Translator.git] / perl-SQL-Translator.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    SQL
6 %define pnam    Translator
7 Summary:        SQL::Translator - manipulate structure data definitions (database schemas)
8 Summary(pl.UTF-8):      SQL::Translator - manipulowanie definicjami struktur danych (schematami baz danych)
9 Name:           perl-SQL-Translator
10 Version:        0.11018
11 Release:        2
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/SQL/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  03db60b963836ba2d264f33d585dffb3
16 URL:            http://search.cpan.org/dist/SQL-Translator/
17 BuildRequires:  perl-Module-Build
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-File-ShareDir >= 1.03
22 BuildRequires:  perl-Class-Base
23 BuildRequires:  perl-Class-Data-Inheritable >= 0.02
24 BuildRequires:  perl-Class-MakeMethods
25 BuildRequires:  perl-DBI
26 BuildRequires:  perl-GD
27 BuildRequires:  perl-GraphViz
28 BuildRequires:  perl-JSON
29 BuildRequires:  perl-Log-Log4perl
30 BuildRequires:  perl-Moo
31 BuildRequires:  perl-Package-Variant >= 1.001001
32 BuildRequires:  perl-Parse-RecDescent >= 1.967009
33 BuildRequires:  perl-Pod-Parser
34 BuildRequires:  perl-Spreadsheet-ParseExcel >= 0.2602
35 BuildRequires:  perl-Template-Toolkit >= 2.10
36 BuildRequires:  perl-Template-Toolkit-Plugin-Date
37 BuildRequires:  perl-Test-Differences
38 BuildRequires:  perl-Test-Exception
39 BuildRequires:  perl-Test-Simple >= 0.60
40 BuildRequires:  perl-Text-RecordParser >= 0.02
41 BuildRequires:  perl-XML-Writer >= 0.500
42 BuildRequires:  perl-XML-XPath >= 1.13
43 BuildRequires:  perl-YAML >= 0.39
44 %endif
45 Requires:       perl-File-ShareDir >= 1.03
46 BuildArch:      noarch
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 # stupid rpm... should invoke perl.req for all files at once
50 %define         _noautoreq      'perl(SQL::Translator.*)'
51
52 %description
53 SQL::Translator is a group of Perl modules that manipulate structure
54 data definitions (mostly database schemas) in interesting ways, such
55 as converting among different dialects of CREATE syntax (e.g.,
56 MySQL-to-Oracle), visualizations of schemas (pseudo-ER diagrams
57 GraphViz or GD), automatic code generation (using Class::DBI),
58 converting non-RDBMS files to SQL schemas (xSV text files, Excel
59 spreadsheets), serializing parsed schemas (via Storable, YAML and
60 XML), creating documentation (HTML and POD), and more. We also have
61 the ability to talk directly to a database through DBI to query for
62 the structures of several databases.
63
64 %description -l pl.UTF-8
65 SQL::Translator to grupa modułów Perla obrabiających definicje danych
66 struktur (głównie schematów baz danych) na ciekawe sposoby, takie jak
67 konwersja między różnymi dialektami składni CREATE (np. MySQL do
68 Oracle), wizualizacja schematów (diagramy pseudo-ER, GraphViz i GD),
69 automatyczne generowanie kodu (przy użyciu Class::DBI), konwersja
70 plików nie będących relacyjnymi bazami danych do schematów SQL (pliki
71 tekstowe xSV, arkusze Excela), serializacja przetworzonych schematów
72 (poprzez Storable, YAML i XML), tworzenie dokumentacji (HTML i POD)
73 itd. Istnieje także możliwość bezpośredniej komunikacji z bazą danych
74 poprzez DBI w celu odpytania o struktury różnych baz.
75
76 %prep
77 %setup -q -n %{pdir}-%{pnam}-%{version}
78
79 %build
80 %{__perl} Makefile.PL \
81         installdirs=vendor \
82         destdir=$RPM_BUILD_ROOT
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc Changes README
98 %attr(755,root,root) %{_bindir}/*
99 %{perl_vendorlib}/SQL/*.pm
100 %{perl_vendorlib}/SQL/Translator
101 %{perl_vendorlib}/Test/SQL
102 %{perl_vendorlib}/auto/share/dist/SQL-Translator
103 %{_mandir}/man?/*
This page took 0.06746 seconds and 4 git commands to generate.