]> git.pld-linux.org Git - packages/perl-SOAP-Lite.git/blob - perl-SOAP-Lite.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-SOAP-Lite.git] / perl-SOAP-Lite.spec
1 # Conditional build:
2 %bcond_with     tests   # perform "make test"
3 #
4 %define         pdir    SOAP
5 %define         pnam    Lite
6 %define         real_version    %(echo %{version} | sed 's/[a-zA-Z]//')
7 Summary:        SOAP::Lite - Client and server side SOAP implementation
8 Summary(pl.UTF-8):      SOAP::Lite - implementacja SOAP po stronie klienta i serwera
9 Name:           perl-SOAP-Lite
10 Version:        1.27
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/P/PH/PHRED/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7d067b73c3b0370cac2af01916590fcb
17 Patch0:         %{name}-warnings.patch
18 URL:            http://www.soaplite.com/
19 %if %{with tests}
20 # this list is probably incomplete
21 BuildRequires:  apache-mod_perl
22 BuildRequires:  perl-Compress-Zlib
23 BuildRequires:  perl-Crypt-SSLeay
24 BuildRequires:  perl-FCGI
25 BuildRequires:  perl-IO-Socket-SSL
26 BuildRequires:  perl-MIME-Base64
27 BuildRequires:  perl-MIME-Lite
28 BuildRequires:  perl-MIME-tools
29 BuildRequires:  perl-URI
30 BuildRequires:  perl-libnet
31 BuildRequires:  perl-libwww
32 %endif
33 BuildRequires:  perl-devel >= 1:5.8.0
34 BuildRequires:  rpm-perlprov >= 4.1-13
35 Obsoletes:      perl-SOAP-Transport-TCP
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # optional
40 %define         _noautoreq_perl SOAP::Transport::HTTP IO::SessionSet IO::SessionData
41
42 %description
43 SOAP::Lite is a collection of Perl modules which provides a simple and
44 lightweight interface to the Simple Object Access Protocol (SOAP) both
45 on client and server side.
46
47 %description -l pl.UTF-8
48 SOAP::Lite to zestaw modułów Perla udostępniających prosty i lekki
49 interfejs do protokołu SOAP (Simple Object Access Protocol) zarówno po
50 stronie klienta, jak i serwera.
51
52 %package HTTP
53 Summary:        HTTP transport support for SOAP::Lite
54 Summary(pl.UTF-8):      Obsługa transportu HTTP dla SOAP::Lite
55 Group:          Development/Languages/Perl
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       perl-libwww
58
59 %description HTTP
60 HTTP transport support for SOAP::Lite (SOAP::Transport::HTTP).
61
62 %description HTTP -l pl.UTF-8
63 Obsługa transportu HTTP dla SOAP::Lite (SOAP::Transport::HTTP).
64
65 %package examples
66 Summary:        SOAP::Lite - examples
67 Summary(pl.UTF-8):      Przykłady użycia SOAP::Lite
68 Group:          Development/Languages/Perl
69
70 %description examples
71 Examples for SOAP::Lite.
72
73 %description examples -l pl.UTF-8
74 Przykłady użycia SOAP::Lite.
75
76 %prep
77 %setup -q -n %{pdir}-%{pnam}-%{real_version}
78 %patch0 -p1
79
80 %build
81 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"SOAP::Lite")' \
82         INSTALLDIRS=vendor
83 %{__make}
84
85 %{?with_tests:%{__make} test}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
94
95 # don't package .pod
96 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/SOAP/*.pod
97
98 # don't package OldDocs
99 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/OldDocs::*
100 rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/OldDocs
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %files
106 %defattr(644,root,root,755)
107 %doc Changes README
108 %{perl_vendorlib}/Apache/*.pm
109 %{perl_vendorlib}/SOAP/*.pm
110 %dir %{perl_vendorlib}/SOAP/Lite
111 %{perl_vendorlib}/SOAP/Lite/*.pm
112 %dir %{perl_vendorlib}/SOAP/Lite/Deserializer
113 %{perl_vendorlib}/SOAP/Lite/Deserializer/*.pm
114 %dir %{perl_vendorlib}/SOAP/Transport
115 %{perl_vendorlib}/SOAP/Transport/*.pm
116 %exclude %{perl_vendorlib}/SOAP/Transport/HTTP.pm
117 %{_mandir}/man3/Apache*
118 %{_mandir}/man3/SOAP*
119
120 %files HTTP
121 %defattr(644,root,root,755)
122 %{perl_vendorlib}/SOAP/Transport/HTTP.pm
123
124 %files examples
125 %defattr(644,root,root,755)
126 %{_examplesdir}/%{name}-%{version}
This page took 0.176476 seconds and 4 git commands to generate.