]> git.pld-linux.org Git - packages/perl-SDL.git/blob - perl-SDL.spec
perl 5.38.0 rebuild
[packages/perl-SDL.git] / perl-SDL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 Summary:        Simple DirectMedia Layer Perl
6 Summary(pl.UTF-8):      Interfejs Simple DirectMedia Layer dla Perla
7 Name:           perl-SDL
8 Version:        2.1.3
9 Release:        20
10 License:        LGPL
11 Group:          Development/Languages/Perl
12 Source0:        http://www.cpan.org/modules/by-authors/id/D/DG/DGOEHRIG/SDL_Perl-%{version}.tar.gz
13 # Source0-md5:  6ce26e1b710ce52def4ec22637cd5176
14 Patch0:         %{name}-gfxPie.patch
15 Patch1:         %{name}-no-mixertest.patch
16 URL:            http://search.cpan.org/dist/SDL_Perl/
17 BuildRequires:  OpenGL-GLU-devel
18 BuildRequires:  SDL-devel
19 BuildRequires:  SDL_gfx-devel >= 2.0.10
20 BuildRequires:  SDL_image-devel
21 BuildRequires:  SDL_mixer-devel
22 BuildRequires:  SDL_net-devel
23 BuildRequires:  SDL_ttf-devel
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libpng-devel
26 BuildRequires:  perl-ExtUtils-CBuilder
27 BuildRequires:  perl-Module-Build
28 BuildRequires:  perl-Test-Simple
29 BuildRequires:  perl-YAML
30 BuildRequires:  perl-devel >= 1:5.8.0
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildRequires:  smpeg-devel
33 Provides:       perl(SDL::OpenGL)
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 SDL_perl is a package of perl modules that provides both functional
38 and object orient interfaces to the Simple DirectMedia Layer for Perl
39 5. This package does take some liberties with the SDL API, and
40 attempts to adhere to the spirit of both the SDL and Perl.
41
42 %description -l pl.UTF-8
43 SDL_perl to pakiet z modułami Perla udostępniający z poziomu Perla
44 interfejsy zarówno funkcjonalne, jak i zorientowane obiektowo do
45 biblioteki SDL (Simple DirectMedia Layer). Pakiet przejmuje trochę
46 swobody z API SDL i próbuje się dopasować do idei SDL oraz Perla.
47
48 %prep
49 %setup -q -n SDL_Perl-%{version}
50 %patch0 -p0
51 %patch1 -p1
52
53 mv t/mixerpm.t{,.blah}  # requires audio device
54
55 %build
56 %{__perl} Build.PL \
57         installdirs=vendor \
58         perl=%{__perl} \
59         destdir=$RPM_BUILD_ROOT \
60         config='optimize=%{rpmcflags}' \
61         config='lddlflags=-shared %{rpmldflags}'
62 ./Build
63
64 # <sigh> I don't know why but for some reason these dirs get put under
65 # blib/arch/auto/src instead of blib/arch/auto causing them to be installed
66 # in the wrong location and "./Build test" to fail. We copy them because if
67 # we move them the next call to ./Build will recreate them in the wrong
68 # location anyways. Unfortunatly with the copy the wrong located originals
69 # will also end up getting installed so we must remove those in %%install
70 cp -r blib/arch/auto/src/SDL* blib/arch/auto
71
72 %{?with_tests:./Build test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 ./Build install
78 rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}/auto/src
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc BUGS CHANGELOG TODO README
86 %{_mandir}/man3/*
87 %{perl_vendorarch}/SDL*.pm
88 %{perl_vendorarch}/SDL
89 %dir %{perl_vendorarch}/auto/SDL
90 %dir %{perl_vendorarch}/auto/SDL_perl
91 %attr(755,root,root) %{perl_vendorarch}/auto/SDL_perl/SDL_perl.so
92 %dir %{perl_vendorarch}/auto/SDL/OpenGL
93 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/OpenGL/OpenGL.so
94 %dir %{perl_vendorarch}/auto/SDL/SFont
95 %attr(755,root,root)%{perl_vendorarch}/auto/SDL/SFont/SFont.so
This page took 0.120962 seconds and 4 git commands to generate.