]> git.pld-linux.org Git - packages/perl-Redis.git/blob - perl-Redis.spec
- update noautoreq for Tie::StdHash, rel 4
[packages/perl-Redis.git] / perl-Redis.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Redis
6 Summary:        Redis - Perl binding for Redis database
7 Name:           perl-Redis
8 Version:        1.998
9 Release:        4
10 # note if it is "same as perl"
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-module/Redis/%{pdir}-%{version}.tar.gz
14 # Source0-md5:  187d464968fdca58eec675856a8cd0fe
15 URL:            http://search.cpan.org/dist/Redis/
16 BuildRequires:  perl-Module-Build-Tiny >= 0.034
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-IO-Socket-Timeout
21 BuildRequires:  perl-IO-String
22 BuildRequires:  perl-Test-Deep
23 BuildRequires:  perl-Test-Exception
24 BuildRequires:  perl-Test-Simple >= 0.96
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # Tie::StdHash is present in Tie/Hash.pm package
30 %define         _noautoreq_perl         Tie::StdHash
31
32 %description
33 Pure Perl bindings for <http://redis.io/>
34
35 This version supports protocol 2.x (multi-bulk) or later of Redis
36 available at <https://github.com/antirez/redis/>.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 %{__make} pure_install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/Redis.pm
60 %{perl_vendorlib}/Redis
61 %{_mandir}/man3/*
This page took 0.137668 seconds and 3 git commands to generate.