]> git.pld-linux.org Git - packages/perl-Readonly.git/blob - perl-Readonly.spec
- summary/description cosmetics
[packages/perl-Readonly.git] / perl-Readonly.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Readonly
7 Summary:        Readonly - facility for creating read-only scalars, arrays, hashes
8 Summary(pl):    Readonly - udogodnienie do tworzenia zmiennych tylko do odczytu
9 Name:           perl-Readonly
10 Version:        1.02
11 Release:        1
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/authors/id/R/RO/ROODE/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  c5da5b0da4a1d6fdbefb15385e9d1baf
16 BuildRequires:  rpm-perlprov >= 4.1-13
17 BuildRequires:  perl-devel >= 5.6.1
18 %if %{?_without_tests:0}%{!?_without_tests:1}
19 BuildRequires:  perl-Test-Simple
20 BuildRequires:  perl-Test-Harness
21 %endif
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25
26 %description
27 This is a facility for creating non-modifiable variables.  This is
28 useful for configuration files, headers, etc.  It can also be useful as
29 a development and debugging tool, for catching updates to variables that
30 should not be changed.
31
32 %description -l pl
33 Readonly umo¿liwia tworzenie niemodyfikowalnych zmiennych.  Jest to
34 u¿yteczne w plikach konfiguracyjnych, nag³ówkach, itp.  Mo¿e byæ tak¿e
35 przydatne jako narzêdzie do rozwijania programów i wyszukiwania b³êdów,
36 wy³apuj±c próby zapisu do zmiennych, które nie powinny byæ zmieniane.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{!?_without_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %doc Changes README
59 %{perl_vendorlib}/*.pm
60 %{_mandir}/man3/*
This page took 0.085188 seconds and 4 git commands to generate.