]> git.pld-linux.org Git - packages/perl-Readonly.git/blob - perl-Readonly.spec
- new, STBR
[packages/perl-Readonly.git] / perl-Readonly.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Readonly
7 Summary:        Readonly - Facility for creating read-only scalars, arrays, hashes.
8 #Summary(pl):   Readonly
9 Name:           perl-Readonly
10 Version:        0.07
11 Release:        1
12 License:        GPL/Artistic
13 Group:          Development/Languages/Perl
14 Source0:        ftp://ftp.cpan.org/pub/CPAN/authors/id/R/RO/ROODE/%{pdir}-%{version}.tar.gz
15 BuildRequires:  rpm-perlprov >= 3.0.3-16
16 BuildRequires:  perl >= 5.6.1
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Test-Simple
19 BuildRequires:  perl-Test-Harness
20 %endif
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24
25 %description
26 This is a facility for creating non-modifiable variables.  This is
27 useful for configuration files, headers, etc.  It can also be useful as
28 a development and debugging tool, for catching updates to variables that
29 should not be changed.
30
31 # %description -l pl
32 # TODO
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 perl Makefile.PL
39 %{__make}
40
41 %{!?_without_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_sitelib}/*.pm
55 %{_mandir}/man3/*
This page took 0.11875 seconds and 4 git commands to generate.