]> git.pld-linux.org Git - packages/perl-Readonly.git/blob - perl-Readonly.spec
- license fixes, cosmetics
[packages/perl-Readonly.git] / perl-Readonly.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Readonly
7 Summary:        Readonly - facility for creating read-only scalars, arrays, hashes
8 Summary(pl):    Readonly - udogodnienie do tworzenia zmiennych tylko do odczytu
9 Name:           perl-Readonly
10 Version:        1.03
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/authors/id/R/RO/ROODE/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  0acef3a995ac9ecf575f66a726d638f4
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRequires:  perl-devel >= 5.6.1
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple
21 BuildRequires:  perl-Test-Harness
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a facility for creating non-modifiable variables.  This is
28 useful for configuration files, headers, etc.  It can also be useful as
29 a development and debugging tool, for catching updates to variables that
30 should not be changed.
31
32 %description -l pl
33 Readonly umo¿liwia tworzenie niemodyfikowalnych zmiennych.  Jest to
34 u¿yteczne w plikach konfiguracyjnych, nag³ówkach, itp.  Mo¿e byæ tak¿e
35 przydatne jako narzêdzie do rozwijania programów i wyszukiwania b³êdów,
36 wy³apuj±c próby zapisu do zmiennych, które nie powinny byæ zmieniane.
37
38 %prep
39 %setup -q -n %{pdir}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorlib}/*.pm
62 %{_mandir}/man3/*
This page took 0.560582 seconds and 4 git commands to generate.