]> git.pld-linux.org Git - packages/perl-Readonly.git/blob - perl-Readonly.spec
- updated to 2.05
[packages/perl-Readonly.git] / perl-Readonly.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Readonly
7 Summary:        Readonly - facility for creating read-only scalars, arrays, hashes
8 Summary(pl.UTF-8):      Readonly - udogodnienie do tworzenia zmiennych tylko do odczytu
9 Name:           perl-Readonly
10 Version:        2.05
11 Release:        1
12 # same as perl 5
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/S/SA/SANKO/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  acae851d7d55c509f5f00a8849597e54
17 URL:            http://search.cpan.org/dist/Readonly/
18 BuildRequires:  perl-Module-Build-Tiny >= 0.035
19 BuildRequires:  perl-devel >= 1:5.8.1
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 BuildRequires:  perl-Test-Harness
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is a facility for creating non-modifiable variables. This is
30 useful for configuration files, headers, etc. It can also be useful as
31 a development and debugging tool, for catching updates to variables
32 that should not be changed.
33
34 %description -l pl.UTF-8
35 Readonly umożliwia tworzenie niemodyfikowalnych zmiennych.  Jest to
36 użyteczne w plikach konfiguracyjnych, nagłówkach, itp.  Może być także
37 przydatne jako narzędzie do rozwijania programów i wyszukiwania
38 błędów, wyłapując próby zapisu do zmiennych, które nie powinny być
39 zmieniane.
40
41 %prep
42 %setup -q -n %{pdir}-%{version}
43
44 %build
45 %{__perl} Build.PL
46
47 ./Build
48
49 %{?with_tests:./Build test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 ./Build install \
55         --destdir=$RPM_BUILD_ROOT \
56         --installdirs=vendor
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README.md
64 %{perl_vendorlib}/Readonly.pm
65 %{_mandir}/man3/Readonly.3pm*
This page took 0.06185 seconds and 4 git commands to generate.