]> git.pld-linux.org Git - packages/perl-RPM-Specfile.git/blob - perl-RPM-Specfile.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-RPM-Specfile.git] / perl-RPM-Specfile.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    RPM
6 %define         pnam    Specfile
7 Summary:        RPM::Specfile - Perl extension for creating RPM specfiles
8 Summary(pl.UTF-8):      RPM::Specfile - rozszerzenie Perla do tworzenia plików .spec dla RPM-a
9 Name:           perl-RPM-Specfile
10 Version:        1.51
11 Release:        1
12 License:        ?
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  023b47c72581ac2190487b7ad0185bcf
16 URL:            http://search.cpan.org/dist/RPM-Specfile/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Simple module for creation of RPM Spec files. Used by cpanflute2 to
24 turn CPAN tarballs into RPM modules. See the included script
25 cpanflute2 for usage; documentation coming soon.
26
27 %description -l pl.UTF-8
28 Prosty moduł do tworzenia plików .spec dla RPM-a. Jest używany przez
29 cpanflute2 do zamiany paczek CPAN na moduły RPM. Sposób użycia można
30 znaleźć w załączonym skrypcie cpanflute2 - dokumentacja wkrótce.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make}
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48 mv $RPM_BUILD_ROOT%{_bindir}/cpanflute2 $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %{perl_vendorlib}/%{pdir}/*.pm
57 %{_mandir}/man3/*
58 %dir %{_examplesdir}/%{name}-%{version}
59 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.111098 seconds and 4 git commands to generate.