]> git.pld-linux.org Git - packages/perl-REST-Client.git/blob - perl-REST-Client.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-REST-Client.git] / perl-REST-Client.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    REST
6 %define         pnam    Client
7 Summary:        REST::Client - A simple client for interacting with RESTful http/https resources
8 Summary(pl.UTF-8):      REST::Client - prosty klient do interakcji z zasobami RESTful http/https
9 Name:           perl-REST-Client
10 Version:        150
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MC/MCRAWFOR/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  143ca1bff9b53bd9b888455328e41eb2
17 URL:            http://search.cpan.org/dist/REST-Client/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 REST::Client provides a simple way to interact with HTTP RESTful
25 resources.
26
27 %description -l pl.UTF-8
28 REST::Client dostarcza prosty sposów na interakcję z zasobami HTTP
29 RESTful.
30
31 %prep
32 %setup -q -n %{pdir}-%{pnam}-%{version}
33
34 %build
35 %{__perl} Makefile.PL \
36         INSTALLDIRS=vendor
37 %{__make}
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc CHANGES
53 %dir %{perl_vendorlib}/REST
54 %{perl_vendorlib}/REST/*.pm
55 %{_mandir}/man3/*
This page took 0.104751 seconds and 4 git commands to generate.