]> git.pld-linux.org Git - packages/perl-Quota.git/blob - perl-Quota.spec
- x32 rebuild
[packages/perl-Quota.git] / perl-Quota.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # interactive
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    Quota
8 %define         pnam    Quota
9 Summary:        Quota - Perl interface to file system quotas
10 Summary(pl.UTF-8):      Quota - perlowy interfejs do quot systemów plików
11 Name:           perl-Quota
12 Version:        1.6.7
13 Release:        5
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/Quota/%{pnam}-%{version}.tar.gz
18 # Source0-md5:  3bc663fa72ec3522f1360d01ddf3b5a5
19 Patch0:         %{name}-paths.patch
20 Patch1:         %{name}-pic.patch
21 URL:            http://search.cpan.org/dist/Quota/
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Quota module provides access to file system quotas.  The quotactl
28 system call or ioctl is used to query or set quotas on the local host,
29 or queries are submitted via RPC to a remote host.  Mount tables can
30 be parsed with getmntent and paths can be translated to device files
31 (or whatever the actual quotactl implementations needs as argument)
32 of the according file system.
33
34 %description -l pl.UTF-8
35 Moduł Quota daje dostęp do quot systemów plików. Używa wywołań
36 systemowych quotactl lub ioctl do sprawdzania lub ustawiania quot
37 lokalnych lub przesyła zapytania po RPC do zdalnej maszyny. Tablice
38 montowanych partycji mogą być analizowane poprzez getmntent, a ścieżki
39 tłumaczone na pliki urządzeń (lub cokolwiek, czego dana implementacja
40 quotactl wymaga jako parametru) odpowiadających im systemów plików.
41
42 %prep
43 %setup -q -n %{pnam}-%{version}
44 %patch0 -p0
45 %patch1 -p1
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 # test is interactive
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63 cp -af contrib/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CHANGES README
71 %{perl_vendorarch}/Quota.pm
72 %dir %{perl_vendorarch}/auto/Quota
73 %{perl_vendorarch}/auto/Quota/autosplit.ix
74 %attr(755,root,root) %{perl_vendorarch}/auto/Quota/Quota.so
75 %{_mandir}/man3/*
76 %dir %{_examplesdir}/%{name}-%{version}
77 %{_examplesdir}/%{name}-%{version}/[Rqr]*
78 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.pl
This page took 0.063088 seconds and 3 git commands to generate.