]> git.pld-linux.org Git - packages/perl-Proc-WaitStat.git/blob - perl-Proc-WaitStat.spec
use generic url
[packages/perl-Proc-WaitStat.git] / perl-Proc-WaitStat.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" - working database connection required
4
5 %define         pdir    Proc
6 %define         pnam    WaitStat
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Proc::WaitStat perl module
9 Summary(pl.UTF-8):      Moduł perla Proc::WaitStat
10 Name:           perl-Proc-WaitStat
11 Version:        1.00
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b911bd579b6b142391b21de1efa30c95
18 URL:            http://search.cpan.org/dist/Proc-WaitStat/
19 BuildRequires:  perl-IPC-Signal
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Proc::WaitStat module contains functions for interpreting and acting
27 on wait status values.
28
29 %description -l pl.UTF-8
30 Moduł Proc::WaitStat zawiera funkcje do interpretowania wartości
31 zwracanych przez wait() i podejmowania określonych działań.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/Proc/WaitStat.pm
56 %{_mandir}/man3/*
This page took 0.129426 seconds and 4 git commands to generate.