]> git.pld-linux.org Git - packages/perl-Pod-Tree.git/blob - perl-Pod-Tree.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Pod-Tree.git] / perl-Pod-Tree.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Pod
6 %define         pnam    Tree
7 Summary:        Pod::Tree - create a static syntax tree for a POD
8 Summary(pl.UTF-8):      Pod::Tree - tworzenie statycznych drzew składniowych dla POD
9 Name:           perl-Pod-Tree
10 Version:        1.17
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Pod/SWMCD/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7ab2dc16736ce37d1bf82e6065107cf5
17 Patch0:         %{name}-carriage_return.patch
18 Patch1:         %{name}-item_warning.patch
19 URL:            http://search.cpan.org/dist/Pod-Tree/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-HTML-Stream >= 1.49
24 BuildRequires:  perl-IO >= 1.23
25 BuildRequires:  perl-Pod-Escapes >= 1.02
26 BuildRequires:  perl-Text-Template >= 1
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Pod::Tree parses a POD into a static syntax tree. Applications walk
33 the tree to recover the structure and content of the POD. See
34 Pod::Tree::Node manual for a description of the tree.
35
36 %description -l pl.UTF-8
37 Pod::Tree przekształca POD na statyczne drzewo składniowe. Aplikacje
38 wędrują po drzewie w celu uzyskania struktury i zawartości z POD. Opis
39 drzewa można znaleźć w manualu do Pod::Tree::Node.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43 %patch0 -p1
44 %patch1 -p1
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60 cp -a skeleton $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README ToDo ToDo.Not
68 %attr(755,root,root) %{_bindir}/mod2html
69 %attr(755,root,root) %{_bindir}/perl2html
70 %attr(755,root,root) %{_bindir}/pods2html
71 %attr(755,root,root) %{_bindir}/podtree2html
72 %{perl_vendorlib}/Pod/Tree.pm
73 %{perl_vendorlib}/Pod/Tree
74 %{_mandir}/man1/mod2html.1p*
75 %{_mandir}/man1/perl2html.1p*
76 %{_mandir}/man1/pods2html.1p*
77 %{_mandir}/man1/podtree2html.1p*
78 %{_mandir}/man3/Pod::Tree*.3pm*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.060037 seconds and 4 git commands to generate.