]> git.pld-linux.org Git - packages/perl-Pod-POM.git/blob - perl-Pod-POM.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Pod-POM.git] / perl-Pod-POM.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Pod
6 %define         pnam    POM
7 Summary:        Pod::POM - POD Object Model
8 Summary(pl.UTF-8):      Pod::POM - Obiektowy model POD (POD Object Model)
9 Name:           perl-Pod-POM
10 Version:        2.01
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Pod/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  a2983236abdcf7842d93f10f9132e46c
17 URL:            http://search.cpan.org/dist/Pod-POM/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-File-Slurper >= 0.004
21 BuildRequires:  perl-Test-Differences
22 BuildRequires:  perl-Text-Diff
23 %endif
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module implements a parser to convert Pod documents into a simple
30 object model form known hereafter as the Pod Object Model.  The object
31 model is generated as a hierarchical tree of nodes, each of which
32 represents a different element of the original document.  The tree can
33 be walked manually and the nodes examined, printed or otherwise
34 manipulated.  In addition, Pod::POM supports and provides view objects
35 which can automatically traverse the tree, or section thereof, and
36 generate an output representation in one form or another.
37
38 %description -l pl.UTF-8
39 Ten moduł jest implementacją parsera konwertującego dokumenty Pod na
40 prostą postać modelu obiektowego, znaną jako Pod Object Model. Model
41 obiektowy jest generowany jako hierarchiczne drzewo węzłów, z których
42 każdy reprezentuje inny element oryginalnego dokumentu. Po drzewie
43 można się przemieszczać ręcznie, sprawdzając, wypisując lub w inny
44 sposób obrabiając węzły. Oprócz tego, Pod::POM obsługuje obiekty
45 widoku, które mogą automatycznie przemieszczać się po drzewie lub jego
46 części i generować na wyjściu reprezentację w jakiejś formie.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README.md TODO
70 %attr(755,root,root) %{_bindir}/podlint
71 %attr(755,root,root) %{_bindir}/pom2
72 %attr(755,root,root) %{_bindir}/pomdump
73 %{perl_vendorlib}/Pod/POM.pm
74 %{perl_vendorlib}/Pod/POM
75 %{_mandir}/man1/podlint.1p*
76 %{_mandir}/man1/pom2.1p*
77 %{_mandir}/man1/pomdump.1p*
78 %{_mandir}/man3/Pod::POM*.3pm*
This page took 0.098178 seconds and 4 git commands to generate.