]> git.pld-linux.org Git - packages/perl-PkgConfig.git/blob - perl-PkgConfig.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-PkgConfig.git] / perl-PkgConfig.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    PkgConfig
6 Summary:        PkgConfig - Pure-Perl Core-Only replacement for pkg-config
7 Summary(pl.UTF-8):      PkgConfig - czysto perlowy zamiennik programu pkg-config
8 Name:           perl-PkgConfig
9 Version:        0.16026
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/P/PL/PLICEASE/PkgConfig-%{version}.tar.gz
15 # Source0-md5:  ae468afd4e21967aa121f748a5329621
16 URL:            http://search.cpan.org/dist/PkgConfig/
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.56
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple >= 0.94
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 PkgConfig provides a pure-perl, core-only replacement for the
28 pkg-config utility.
29
30 %description -l pl.UTF-8
31 Moduł PkgConfig zawiera czysto perlowy, nie korzystający z
32 zewnętrznych modułów zamiennik programu pkg-config.
33
34 %prep
35 %setup -q -n %{pdir}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %attr(755,root,root) %{_bindir}/pkg-config.pl
57 %attr(755,root,root) %{_bindir}/ppkg-config
58 %{perl_vendorlib}/PkgConfig.pm
59 %{_mandir}/man1/pkg-config.pl.1p*
60 %{_mandir}/man1/ppkg-config.1p*
61 %{_mandir}/man3/PkgConfig.3pm*
This page took 0.352999 seconds and 4 git commands to generate.