]> git.pld-linux.org Git - packages/perl-Perl-Critic.git/blob - perl-Perl-Critic.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Perl-Critic.git] / perl-Perl-Critic.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    Perl
6 %define pnam    Critic
7 Summary:        Perl::Critic - Critique Perl source code for best-practices
8 Summary(pl.UTF-8):      Perl::Critic - krytyka kodu źródłowego w Perla pod kątem najlepszych praktyk
9 Name:           perl-Perl-Critic
10 Version:        1.132
11 Release:        2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Perl/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  76042c0516190419e0424f10366231ae
17 URL:            http://search.cpan.org/dist/Perl-Critic/
18 BuildRequires:  perl-B-Keywords >= 1.05
19 BuildRequires:  perl-List-MoreUtils >= 0.19
20 BuildRequires:  perl-Module-Build >= 0.4200
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl(Exporter) >= 5.63
25 BuildRequires:  perl-Config-Tiny >= 2
26 BuildRequires:  perl-Email-Address >= 1.889
27 BuildRequires:  perl-Exception-Class >= 1.23
28 BuildRequires:  perl-IO-String
29 BuildRequires:  perl-Module-Pluggable >= 3.1
30 BuildRequires:  perl-PPI >= 1.224
31 BuildRequires:  perl-PPIx-Regexp >= 0.027
32 BuildRequires:  perl-PPIx-Utilities >= 1.001
33 BuildRequires:  perl-PPIx-QuoteLike
34 BuildRequires:  perl-PadWalker
35 BuildRequires:  perl-Pod-Spell >= 1
36 BuildRequires:  perl-Readonly >= 2.00
37 BuildRequires:  perl-String-Format >= 1.13
38 BuildRequires:  perl-Task-Weaken
39 BuildRequires:  perl-Test-Deep
40 BuildRequires:  perl-Test-Memory-Cycle
41 BuildRequires:  perl-Test-Simple >= 0.92
42 BuildRequires:  perl-version >= 0.77
43 BuildRequires:  perltidy
44 %endif
45 Requires:       perl(Exporter) >= 5.63
46 Requires:       perl-B-Keywords >= 1.05
47 Requires:       perl-Config-Tiny >= 2
48 Requires:       perl-Email-Address >= 1.889
49 Requires:       perl-Exception-Class >= 1.23
50 Requires:       perl-List-MoreUtils >= 0.19
51 Requires:       perl-Module-Pluggable >= 3.1
52 Requires:       perl-PPI >= 1.220
53 Requires:       perl-PPIx-Regexp >= 0.027
54 Requires:       perl-PPIx-Utilities >= 1.001
55 Requires:       perl-Readonly >= 2.00
56 Requires:       perl-String-Format >= 1.13
57 Requires:       perl-dirs >= 4-4
58 Requires:       perl-version >= 0.77
59 Suggests:       perl-Term-ANSIColor >= 2.02
60 BuildArch:      noarch
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _noautoreq      'perl(Perl::Critic.*)'
64
65 %description
66 Perl::Critic is an extensible framework for creating and applying
67 coding standards to Perl source code. Essentially, it is a static
68 source code analysis engine. Perl::Critic is distributed with a
69 number of Perl::Critic::Policy modules that attempt to enforce
70 various coding guidelines. Most Policy modules are based on Damian
71 Conway's book Perl Best Practices. However, Perl::Critic is not
72 limited to PBP and will even support Policies that contradict Conway.
73 You can enable, disable, and customize those Polices through the
74 Perl::Critic interface. You can also create new Policy modules that
75 suit your own tastes.
76
77 %description -l pl.UTF-8
78 Perl::Critic to rozszerzalny szkielet do tworzenia i nanoszenia
79 standardów kodowania dla kodu źródłowego w Perlu. Zasadniczo jest to
80 statyczny silnik do analizy kodu źródłowego. Perl::Critic jest
81 rozpowszechniany z wieloma modułami Perl::Critic::Policy, próbującymi
82 wymusić różne wskazania dotyczące kodowania. Większość modułów Policy
83 jest oparta na książce "Perl Best Practices" Damiana Conwaya. Jednak
84 Perl::Critic nie jest ograniczony do PDB i będzie obsługiwał polityki
85 nawet niezgodne z Conwayem. Poprzez interfejs Perl::Critic można
86 włączać, wyłączać i dostrajać polityki. Można także tworzyć nowe
87 moduły Policy odpowiadające własnym gustom.
88
89 %prep
90 %setup -q -n %{pdir}-%{pnam}-%{version}
91
92 %build
93 %{__perl} Build.PL \
94         destdir=$RPM_BUILD_ROOT \
95         installdirs=vendor
96 ./Build
97
98 %{?with_tests:./Build test}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 ./Build install
104
105 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Perl/Critic/*.pod
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %files
111 %defattr(644,root,root,755)
112 %doc Changes README.md TODO.pod extras
113 %attr(755,root,root) %{_bindir}/perlcritic
114 %{perl_vendorlib}/Perl/Critic.pm
115 %{perl_vendorlib}/Perl/Critic
116 %dir %{perl_vendorlib}/Test/Perl/Critic
117 %{perl_vendorlib}/Test/Perl/Critic/Policy.pm
118 %{_mandir}/man1/perlcritic.1*
119 %{_mandir}/man3/Perl::Critic*.3pm*
120 %{_mandir}/man3/Test::Perl::Critic::Policy.3pm*
This page took 0.077908 seconds and 4 git commands to generate.