]> git.pld-linux.org Git - packages/perl-Pegex.git/blob - perl-Pegex.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Pegex.git] / perl-Pegex.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Pegex
6 Summary:        Pegex - Acmeist PEG Parser Framework
7 Summary(pl.UTF-8):      Pegex - szkielet analizatora Acmeist PEG
8 Name:           perl-Pegex
9 Version:        0.60
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/I/IN/INGY/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  347f72c1c0347148d80058ea35927df8
16 URL:            http://search.cpan.org/dist/Pegex/
17 BuildRequires:  perl-File-ShareDir-Install >= 0.06
18 BuildRequires:  perl-devel >= 1:5.8.1
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-YAML-LibYAML
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Pegex is an Acmeist parser framework. It allows you to easily create
28 parsers that will work equivalently in lots of programming languages!
29 The inspiration for Pegex comes from the parsing engine upon which the
30 postmodern programming language Perl 6 is based on. Pegex brings this
31 beauty to the other justmodern languages that have a normal regular
32 expression engine available.
33
34 Pegex gets it name by combining Parsing Expression Grammars (PEG),
35 with Regular Expessions (Regex). That's actually what Pegex does.
36
37 %description -l pl.UTF-8
38 Pegex to szkielet analizatora Acmeist. Pozwala łatwo tworzyć
39 analizatory działające tak samo w wielu językach programowania. Pegex
40 jest zainspirowany silnikiem analizującym, na którym jest oparty
41 postmodernistyczny język Perl 6. Pegex dostarcza o piękno do innych
42 współczesnych języków, mających dostępny zwykły silnik wyrażeń
43 regularnych.
44
45 Nazwa Pegex pochodzi z połączenia skrótu PEG (Parsing Expression
46 Grammars) z Regex (Regular Expressions). I oznacza to, co właściwie
47 Pegex robi.
48
49 %prep
50 %setup -q -n %{pdir}-%{version}
51
52 %build
53 %{__perl} Makefile.PL \
54         INSTALLDIRS=vendor
55 %{__make}
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/Pegex.pod
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 cp -a example $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes
76 %{perl_vendorlib}/Pegex.pm
77 %{perl_vendorlib}/Pegex
78 %{perl_vendorlib}/auto/share/dist/Pegex
79 %{_mandir}/man3/Pegex.3pm*
80 %{_mandir}/man3/Pegex::*.3pm*
81 %{_examplesdir}/%{name}-%{version}
This page took 0.075685 seconds and 3 git commands to generate.