]> git.pld-linux.org Git - packages/perl-Params-Classify.git/blob - perl-Params-Classify.spec
- rebuild with perl 5.18.0
[packages/perl-Params-Classify.git] / perl-Params-Classify.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Params
6 %define         pnam    Classify
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Params::Classify - argument type classification
9 Summary(pl.UTF-8):      Params::Classify - klasyfikacja typu argumentu
10 Name:           perl-Params-Classify
11 Version:        0.013
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Params/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  63d24fbec775472ada49d16bce4a9b1f
18 URL:            http://search.cpan.org/dist/Params-Classify/
19 BuildRequires:  perl-ExtUtils-ParseXS >= 2.2006
20 BuildRequires:  perl-Module-Build
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-Scalar-List-Utils >= 1.01
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides various type-testing functions. These are
30 intended for functions that, unlike most Perl code, care what type of
31 data they are operating on. For example, some functions wish to
32 behave differently depending on the type of their arguments (like
33 overloaded functions in C++).
34
35 %description -l pl.UTF-8
36 Ten moduł udostępnia różne funkcje do sprawdzania typów. Mają być
37 przydatne dla funkcji, które - w przeciwieństwie do większości kodu
38 perlowego - zwracają uwagę na typ danych, na których operują; np.
39 dla funkcji, które zachowują się różnie w zależności od typu
40 argumentów (jak przeciążone funkcje w C++).
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Build.PL \
47         installdirs=vendor \
48         --config cc="%{__cc}" \
49         --config ld="%{__cc}" \
50         --config optimize="%{rpmcflags}"
51
52 ./Build
53
54 %{?with_tests:./Build test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 ./Build install \
60         destdir=$RPM_BUILD_ROOT
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorarch}/Params/Classify.pm
69 %dir %{perl_vendorarch}/auto/Params/Classify
70 %{perl_vendorarch}/auto/Params/Classify/Classify.bs
71 %attr(755,root,root) %{perl_vendorarch}/auto/Params/Classify/Classify.so
72 %{_mandir}/man3/Params::Classify.3pm*
This page took 0.766089 seconds and 4 git commands to generate.