]> git.pld-linux.org Git - packages/perl-Parallel-Prefork.git/blob - perl-Parallel-Prefork.spec
- added
[packages/perl-Parallel-Prefork.git] / perl-Parallel-Prefork.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Parallel
6 %define         pnam    Prefork
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Parallel::Prefork - A simple prefork server framework
9 #Summary(pl.UTF-8):     
10 Name:           perl-Parallel-Prefork
11 Version:        0.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Parallel/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  d4b9347c414e7f0d30708e14e05ee3a6
18 # generic URL, check or change before uncommenting
19 #URL:           http://search.cpan.org/dist/Parallel-Prefork/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl(Class::Accessor::Lite) >= 0.04
24 BuildRequires:  perl(Proc::Wait3) >= 0.03
25 BuildRequires:  perl(Scope::Guard)
26 BuildRequires:  perl-List-MoreUtils
27 BuildRequires:  perl-Test-Requires
28 %endif
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Parallel::Prefork is much like Parallel::ForkManager, but supports graceful shutdown and run-time reconfiguration.
34
35
36
37 # %description -l pl.UTF-8
38 # TODO
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorlib}/Parallel/*.pm
63 %{perl_vendorlib}/Parallel/Prefork
64 %{_mandir}/man3/*
This page took 0.149475 seconds and 4 git commands to generate.