]> git.pld-linux.org Git - packages/perl-Pango.git/blob - perl-Pango.spec
perl 5.38.0 rebuild
[packages/perl-Pango.git] / perl-Pango.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires DISPLAY)
4 #
5 %define pdir    Pango
6 Summary:        Pango - Layout and render international text
7 Summary(pl.UTF-8):      Pango - rozmieszczanie i renderowanie wielojęzycznego tekstu
8 Name:           perl-Pango
9 Version:        1.227
10 Release:        5
11 License:        LGPL v2.1+
12 Group:          Development/Languages/Perl
13 Source0:        http://downloads.sourceforge.net/gtk2-perl/Pango-%{version}.tar.gz
14 # Source0-md5:  cc5d7ca7780adcc5cee7cc41f2fc0440
15 URL:            http://search.cpan.org/dist/Pango/
16 BuildRequires:  pango-devel >= 1:1.16
17 BuildRequires:  perl-ExtUtils-Depends >= 0.300
18 BuildRequires:  perl-ExtUtils-PkgConfig >= 1.03
19 BuildRequires:  perl-Glib-devel >= 1.220
20 BuildRequires:  perl-Cairo-devel >= 1.000
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRequires:  rpmbuild(macros) >= 1.745
24 %if %{with tests}
25 # some fonts are required, but does not really matter which ones
26 BuildRequires:  fonts-TTF-bitstream-vera
27 BuildRequires:  perl-Gtk2 >= 1.220
28 %endif
29 Requires:       pango >= 1:1.16
30 Requires:       perl-Glib >= 1.220
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Perl bindings to Pango library used to layout and render international
35 text.
36
37 %description -l pl.UTF-8
38 Perlowe wiązania do biblioteki Pango służącej do rozmieszczania i
39 renderowania wielojęzycznego tekstu.
40
41 %package devel
42 Summary:        Development files for Perl Pango bindings
43 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pango dla Perla
44 Group:          Development/Languages/Perl
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       pango-devel >= 1:1.16
47 Requires:       perl-Glib-devel >= 1.220
48
49 %description devel
50 Development files for Perl Pango bindings.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne wiązań Pango dla Perla.
54
55 %prep
56 %setup -q -n %{pdir}-%{version}
57
58 %build
59 %{__perl} Makefile.PL \
60         INSTALLDIRS=vendor
61 %{__make} \
62         CC="%{__cc}" \
63         OPTIMIZE="%{rpmcflags}"
64
65 %{?with_tests:%{__make} test}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} pure_install \
71         DESTDIR=$RPM_BUILD_ROOT
72
73 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
74 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
75
76 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Pango{,/Cairo}/*.pod
77 rmdir $RPM_BUILD_ROOT%{perl_vendorarch}/Pango/Cairo
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS NEWS README
85 %{perl_vendorarch}/Pango.pm
86 %dir %{perl_vendorarch}/Pango
87 %dir %{perl_vendorarch}/auto/Pango
88 %attr(755,root,root) %{perl_vendorarch}/auto/Pango/Pango.so
89 %{_mandir}/man3/Pango*.3pm*
90 %{_examplesdir}/%{name}-%{version}
91
92 %files devel
93 %defattr(644,root,root,755)
94 %{perl_vendorarch}/Pango/Install
This page took 0.172494 seconds and 4 git commands to generate.