]> git.pld-linux.org Git - packages/perl-POE.git/blame - perl-POE.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE.git] / perl-POE.spec
CommitLineData
3cc62918 1#
2# Conditional build:
d68844b4 3%bcond_without tests # do not perform "make test"
3cc62918 4#
601627ed 5%define pdir POE
a61a7cb5 6Summary: POE - multitasking and networking framework for Perl
e98149ff 7Summary(pl.UTF-8): POE - wielozadaniowe i sieciowe środowisko dla Perla
3cc62918 8Name: perl-POE
53291eac 9Version: 1.367
d2de4fdf 10Release: 1
64ed78f8 11Epoch: 2
3cc62918 12# same as perl
a61a7cb5 13License: GPL v1+ or Artistic
3cc62918 14Group: Development/Languages/Perl
944e3949 15Source0: http://www.cpan.org/modules/by-module/POE/%{pdir}-%{version}.tar.gz
53291eac 16# Source0-md5: 9b2e4375152b139e4ab5f7dfb2cc5b15
3cc62918 17URL: http://poe.perl.org/
c24bed54 18BuildRequires: perl-devel >= 1:5.8.0
3cc62918 19BuildRequires: rpm-perlprov >= 4.1-13
f4f8fd68 20BuildRequires: perl-Test-Simple >= 0.54
d68844b4 21%if %{with tests}
3cc62918 22BuildRequires: perl(Filter::Util::Call) >= 1.04
03d3f0b1 23BuildRequires: perl-IO-Compress
3cc62918 24BuildRequires: perl-Curses
25BuildRequires: perl-Event
03d3f0b1 26BuildRequires: perl-IO-Tty >= 1.08
19c3ac1f 27BuildRequires: perl-Socket6 >= 0.14
28BuildRequires: perl-Storable >= 2.12
29BuildRequires: perl-Term-ReadKey >= 2.21
30BuildRequires: perl-Time-HiRes >= 1.59
31BuildRequires: perl-URI >= 1.30
3cc62918 32BuildRequires: perl-libwww
33%endif
0cb05eca 34Conflicts: perl-POE-Filter-XML < 0.29
78fe800a 35Obsoletes: perl-POE-Exceptions
3cc62918 36BuildArch: noarch
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
67b52fc5 39%define _noautoreq perl(Curses) perl(HTTP::Date) perl(HTTP::Request) perl(HTTP::Response) perl(HTTP::Status) perl(URI) perl(Term::Cap) perl(Term::ReadKey) perl(Tk)
3cc62918 40
41%description
42POE is an acronym of "Perl Object Environment". It's a networking
43and multitasking (some say cooperative threading) framework for Perl.
44It has been in active development since 1996, with its first open
45release in 1998. O'Reilly's Perl Conference (now OSCON) named POE
46"Best New Module" in 1999.
47
48POE has been used in mission-critical systems such as internetworked
49financial markets, file systems, commerce and application servers.
50It has been used in projects ranging from a few lines of code to tens
51of thousands.
52
53POE is compatible with perl versions as old as 5.005_03.
54
55POE includes an evolving component framework. Components are high-level,
56modular, reusable pieces of programs. Several components have been
57published on the CPAN, and more are listed on POE's web site.
58
59POE includes components and libraries for making quick work of network
60clients, servers, and peers. A simple stand-alone web application takes
61about 30 lines of code, most of which is your own custom logic.
62
43b3d8a9
JR
63%description -l pl.UTF-8
64POE to skrót od "Perl Object Environment" (co oznacza "środowisko
65obiektowe Perla"). Jest to szkielet obsługi sieci i wielozadaniowości
66(nazywanej przez niektórych "kooperatywnym wątkowaniem") dla Perla.
a61a7cb5 67Jest aktywnie rozwijane od 1996 roku, a pierwsze publiczne wydanie
43b3d8a9
JR
68było w 1998 roku. Na O'Reilly's Perl Conference (teraz OSCON) w 1999
69roku POE zostało nazwane "Najlepszym nowym modułem".
a61a7cb5 70
43b3d8a9
JR
71POE jest używane w systemach mission-critical, takich jak
72międzysieciowe rynki finansowe, systemy plików, serwery aplikacji i
73handlowe. Jest używane w projektach o rozmiarach od kilku linii do
74dziesiątek tysięcy.
a61a7cb5
JB
75
76POE jest kompatybilne z Perlem od wersji 5.005_03.
77
43b3d8a9
JR
78POE zawiera rozwijający się szkielet komponentów. Komponenty to
79wysokopoziomowe, modularne, dające się wielokrotnie wykorzystywać
80kawałki programów. Część komponentów została opublikowana w CPAN,
81więcej można znaleźć na stronie WWW POE.
a61a7cb5 82
43b3d8a9
JR
83POE zawiera komponenty i biblioteki do szybkiego tworzenia klientów,
84serwerów i partnerów sieciowych. Prosta, samodzielna aplikacja WWW
85zajmuje około 30 linii kodu, z których większość to właściwa logika.
3cc62918 86
87%prep
88%setup -q -n %{pdir}-%{version}
2b724f66 89rm -f lib/POE/Filter/HTTPD.pm{~.orig}
3cc62918 90
91%build
92%{__perl} Makefile.PL \
93 INSTALLDIRS=vendor \
94 --default
95%{__make}
96
19c3ac1f 97%{?with_tests:%{__make} test}
3cc62918 98
3cc62918 99%install
100rm -rf $RPM_BUILD_ROOT
2886c094 101install -d $RPM_BUILD_ROOT%{perl_vendorlib}/POE/{Component/CD,Session}
3cc62918 102
103%{__make} install \
104 DESTDIR=$RPM_BUILD_ROOT
39d5068c 105install -d $RPM_BUILD_ROOT%{_examplesdir}
89920b49 106cp -r examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
39d5068c 107
3cc62918 108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(644,root,root,755)
19c3ac1f 113%doc CHANGES HISTORY README TODO
39d5068c 114%{perl_vendorlib}/*.pm
2886c094 115%{perl_vendorlib}/POE
89920b49 116%dir %{_examplesdir}/%{name}-%{version}
117%{_examplesdir}/%{name}-%{version}/README*
118%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*.perl
3cc62918 119%{_mandir}/man3/*
This page took 0.189288 seconds and 4 git commands to generate.