]> git.pld-linux.org Git - packages/perl-POE-Component-JobQueue.git/blob - perl-POE-Component-JobQueue.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-JobQueue.git] / perl-POE-Component-JobQueue.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    POE
6 %define         pnam    Component-JobQueue
7 Summary:        POE::Component::JobQueue - a component to manage queues and worker pools
8 Summary(pl.UTF-8):      POE::Component::JobQueue - komponent do zarządzania kolejkami i robotnikami
9 Name:           perl-POE-Component-JobQueue
10 Version:        0.571
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  4b6d96b08ac72fb4ba131017f36407a2
17 URL:            http://search.cpan.org/dist/POE-Component-JobQueue/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-POE >= 1:1.007
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 POE::Component::JobQueue manages a finite pool of worker sessions as
28 they handle an arbitrarily large number of tasks. It often is used as
29 a form of flow control, preventing a large group of tasks from
30 exhausting some sort of resource.
31
32 %description -l pl.UTF-8
33 POE::Component::JobQueue zarządza skończoną pulą sesji robotników
34 wykonujących dowolnie dużą liczbę zadań. Jest często używany jako
35 forma kontroli przepływu, nie pozwalając dużej grupie zadań na
36 wyczerpanie jakiegoś rodzaju zasobu.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES
60 %{perl_vendorlib}/%{pdir}/*/*.pm
61 %{_mandir}/man3/*
This page took 0.217501 seconds and 4 git commands to generate.