]> git.pld-linux.org Git - packages/perl-POE-Component-Client-DNS.git/blob - perl-POE-Component-Client-DNS.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-POE-Component-Client-DNS.git] / perl-POE-Component-Client-DNS.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %define         pdir    POE
6 %define         pnam    Component-Client-DNS
7 Summary:        POE component for non-blocking/concurrent DNS queries
8 Summary(pl.UTF-8):      Komponent POE do wykonywania nieblokujących/równoczesnych zapytań DNS
9 Name:           perl-POE-Component-Client-DNS
10 Version:        1.051
11 Release:        1
12 Epoch:          1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/POE/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ba9bb11cd097b2348ee3d14de3ab432a
18 URL:            http://search.cpan.org/dist/POE-Component-Client-DNS/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Net-DNS >= 0.53
23 BuildRequires:  perl-POE >= 1:0.3100
24 %endif
25 Requires:       perl-POE >= 1:0.3100
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 POE::Component::Client::DNS is a wrapper for non-blocking Net::DNS.
31 It lets other tasks to run while something is waiting for a nameserver
32 to respond, and it lets several DNS queries run in parallel.
33
34 %description -l pl.UTF-8
35 POE::Component::Client::DNS to interfejs do nieblokującej klasy
36 Net::DNS. Pozwala na wykonywanie innych zadań podczas gdy coś czeka na
37 odpowiedź serwera nazw, a także pozwala na równoległe wykonywanie
38 kilku zapytań DNS.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc CHANGES README
62 %{perl_vendorlib}/POE/Component/Client/*.pm
63 %{_mandir}/man3/*
This page took 0.14254 seconds and 4 git commands to generate.