]> git.pld-linux.org Git - packages/perl-Net-Twitter-Lite.git/blob - perl-Net-Twitter-Lite.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-Twitter-Lite.git] / perl-Net-Twitter-Lite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    Twitter-Lite
7 Summary:        Net::Twitter::Lite - A perl interface to the Twitter API
8 #Summary(pl.UTF-8):
9 Name:           perl-Net-Twitter-Lite
10 Version:        0.10004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/M/MM/MMIMS/Net-Twitter-Lite-%{version}.tar.gz
16 # Source0-md5:  eb484488a1a3aa2100986c18844fcd19
17 URL:            http://search.cpan.org/dist/Net-Twitter-Lite/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Crypt-SSLeay >= 0.50
22 BuildRequires:  perl-Encode
23 BuildRequires:  perl-JSON-Any >= 1.21
24 BuildRequires:  perl-Net-OAuth >= 0.25
25 BuildRequires:  perl-URI
26 BuildRequires:  perl-libwww >= 2.032
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 This module provides a perl interface to the Twitter APIs. It uses the
33 same API definitions as Net::Twitter, but without the extra bells and
34 whistles and without the additional dependencies. Same great taste,
35 less filling.
36
37 This module is related to, but is not part of the Net::Twitter
38 distribution. It's API methods and API method documentation are
39 generated from Net::Twitter's internals. It exists for those who
40 cannot, or prefer not to install Moose and its dependencies.
41
42 You should consider upgrading to Net::Twitter for additional
43 functionality, finer grained control over features, full backwards
44 compatibility with older versions of Net::Twitter, and additional
45 error handling options.
46
47 # %description -l pl.UTF-8
48 # TODO
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 %{__perl} Makefile.PL --skip \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc Changes README
75 %dir %{perl_vendorlib}/Net/Twitter
76 %{perl_vendorlib}/Net/Twitter/*.pm
77 %dir %{perl_vendorlib}/Net/Twitter/Lite
78 %{perl_vendorlib}/Net/Twitter/Lite/*.pm
79 %{_mandir}/man3/*
80 %{_examplesdir}/%{name}-%{version}
This page took 0.063975 seconds and 3 git commands to generate.