]> git.pld-linux.org Git - packages/perl-Net-SNMP.git/blob - perl-Net-SNMP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SNMP.git] / perl-Net-SNMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SNMP
7 Summary:        Net::SNMP - object oriented interface to SNMP
8 Summary(pl.UTF-8):      Net::SNMP - zorientowany obiektowo interfejs do SNMP
9 Name:           perl-Net-SNMP
10 Version:        6.0.1
11 Release:        2
12 # same as perl
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-v%{version}.tar.gz
16 # Source0-md5:  6137f04f9942d703f66179f890e3d096
17 Patch0:         %{name}-kill_vstring.patch
18 URL:            http://search.cpan.org/dist/Net-SNMP/
19 BuildRequires:  perl-Crypt-DES >= 2.0.3
20 BuildRequires:  perl-Digest-HMAC
21 BuildRequires:  perl-Digest-SHA1
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-Crypt-DES >= 2.0.3
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # optional (not required if not using v6)
29 %define         _noautoreq      perl(Socket6) perl(IO::Socket::INET6)
30
31 %description
32 The Net::SNMP Perl module implements an object oriented interface to
33 the Simple Network Management Protocol. Perl applications can use the
34 module to retrieve or update information on a remote host using the
35 SNMP protocol. The module supports SNMP version-1, SNMP version-2c
36 (Community-Based SNMPv2), and SNMP version-3. The Net::SNMP module
37 assumes that the user has a basic understanding of the Simple Network
38 Management Protocol and related network management concepts.
39
40 %description -l pl.UTF-8
41 Moduł Perla Net::SNMP stanowi zorientowaną obiektowo implementację
42 interfejsu do protokołu SNMP (Simple Network Management Protocol).
43 Programy perlowe mogą korzystać z tego modułu do pobierania i
44 aktualizacji informacji na zdalnych hostach używając protokołu SNMP.
45 Moduł ten obsługuje wersje protokołu SNMP: 1, 2c (Community-Based
46 SNMPv2) oraz 3. Moduł Net::SNMP zakłada, że użytkownik rozumie w
47 podstawowym zakresie protokół SNMP i związane z nim idee zarządzania
48 sieciowego.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-v%{version}
52 %patch0 -p1
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README Changes
75 %attr(755,root,root) %{_bindir}/snmpkey
76 %{perl_vendorlib}/Net/SNMP.pm
77 %{perl_vendorlib}/Net/SNMP
78 %{_mandir}/man1/snmpkey.1p*
79 %{_mandir}/man3/Net::SNMP.3pm*
80 %{_examplesdir}/%{name}-%{version}
This page took 0.058662 seconds and 3 git commands to generate.