]> git.pld-linux.org Git - packages/perl-Net-SNMP.git/blob - perl-Net-SNMP.spec
- Socket6 and IO::Socket::INET6 are optional
[packages/perl-Net-SNMP.git] / perl-Net-SNMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    SNMP
8 Summary:        Net::SNMP - object oriented interface to SNMP
9 Summary(pl):    Net::SNMP - zorientowany obiektowo interfejs do SNMP
10 Name:           perl-Net-SNMP
11 Version:        5.0.1
12 Release:        1
13 # same as perl
14 License:        GPL or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  840e17ee75a68cad98c53a54d65b8751
18 Patch0:         %{name}-kill_vstring.patch
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  perl-Crypt-DES >= 2.0.3
21 BuildRequires:  perl-Digest-HMAC
22 BuildRequires:  perl-Digest-SHA1
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 Requires:       perl-Crypt-DES >= 2.0.3
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # optional (not required if not using v6)
29 %define         _noautoreq      perl(Socket6) perl(IO::Socket::INET6)
30
31 %description
32 The Net::SNMP Perl module implements an object oriented interface to
33 the Simple Network Management Protocol.  Perl applications can use the
34 module to retrieve or update information on a remote host using the
35 SNMP protocol.  The module supports SNMP version-1, SNMP version-2c
36 (Community-Based SNMPv2), and SNMP version-3.  The Net::SNMP module
37 assumes that the user has a basic understanding of the Simple Network
38 Management Protocol and related network management concepts.
39
40 %description -l pl
41 Modu³ Perla Net::SNMP stanowi zorientowan± obiektowo implementacjê
42 interfejsu do protoko³u SNMP (Simple Network Management Protocol).
43 Programy perlowe mog± korzystaæ z tego modu³u do pobierania i
44 aktualizacji informacji na zdalnych hostach u¿ywaj±c protoko³u SNMP.
45 Modu³ ten obs³uguje wersje protoko³u SNMP: 1, 2c (Community-Based
46 SNMPv2) oraz 3. Modu³ Net::SNMP zak³ada, ¿e u¿ytkownik rozumie w
47 podstawowym zakresie protokó³ SNMP i zwi±zane z nim idee zarz±dzania
48 sieciowego.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52 %patch0 -p0
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README* Changes
73 %attr(755,root,root) %{_bindir}/*
74 %{perl_vendorlib}/Net/*.pm
75 %{perl_vendorlib}/Net/SNMP
76 %{_mandir}/man?/*
This page took 0.078913 seconds and 3 git commands to generate.