]> git.pld-linux.org Git - packages/perl-Net-SMTP_auth.git/blob - perl-Net-SMTP_auth.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SMTP_auth.git] / perl-Net-SMTP_auth.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    SMTP_auth
7 Summary:        Simple Mail Transfer Protocol Client with AUTHentication
8 Summary(pl.UTF-8):      Klient SMTP (Simple Mail Transfer Protocol) z uwierzytelnianiem (SMTP AUTH)
9 Name:           perl-Net-SMTP_auth
10 Version:        0.08
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  23a911893c92c7c26ab9a78882691d9c
17 URL:            http://search.cpan.org/dist/Net-SMTP_auth/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Authen-SASL >= 2.03
22 BuildRequires:  perl-Digest-HMAC >= 1
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module implements a client interface to the SMTP and ESMTP
29 protocol AUTH service extension, enabling a perl5 application to talk
30 to and authenticate against SMTP servers.
31
32 The Net::SMTP_auth class is a subclass of Net::SMTP, which itself is a
33 subclass of Net::Cmd and IO::Socket::INET.
34
35 %description -l pl.UTF-8
36 Ten moduł implementuje interfejs kliencki do rozszerzenia AUTH
37 protokołów SMTP i ESMTP, umożliwiając perlowym aplikacjom rozmawianie
38 i uwierzytelnianie względem serwerów SMTP.
39
40 Klasa Net::SMTP_auth jest podklasą Net::SMTP, która z kolei jest
41 podklasą Net::Cmd i IO::Socket::INET.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorlib}/Net/SMTP_auth.pm
67 %{_mandir}/man3/*
This page took 0.13021 seconds and 4 git commands to generate.