]> git.pld-linux.org Git - packages/perl-Net-SMTP-TLS.git/commitdiff
- rel 3; patches from debian that fix sending using tls master auto/th/perl-Net-SMTP-TLS-0.12-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 29 Jan 2020 09:18:28 +0000 (10:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 29 Jan 2020 09:18:28 +0000 (10:18 +0100)
io-socket-ssl.patch [new file with mode: 0644]
multiple-attachments.patch [new file with mode: 0644]
perl-Net-SMTP-TLS.spec

diff --git a/io-socket-ssl.patch b/io-socket-ssl.patch
new file mode 100644 (file)
index 0000000..20e864d
--- /dev/null
@@ -0,0 +1,22 @@
+Description: Fix syntax problem in IO::Socket::SSL call.
+ The usage of SSL_version was wrong, and IO::Socket::SSL uses sensible defaults anyway.
+ Cf. also https://rt.cpan.org/Public/Bug/Display.html?id=77401 .
+Origin: vendor
+Bug: https://rt.cpan.org/Ticket/Display.html?id=85637
+Bug-Debian: https://bugs.debian.org/728660
+Author: Steffen Ullrich <sullr@cpan.org>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2017-01-26
+
+--- a/lib/Net/SMTP/TLS.pm
++++ b/lib/Net/SMTP/TLS.pm
+@@ -178,8 +178,7 @@
+       if(not $num == 220){
+               croak "Invalid response for STARTTLS: $num $txt\n";
+       }
+-      if(not IO::Socket::SSL::socket_to_SSL($me->{sock},
+-              SSL_version     =>      "SSLv3 TLSv1")){
++      if(not IO::Socket::SSL::socket_to_SSL($me->{sock})){
+                       croak "Couldn't start TLS: ".IO::Socket::SSL::errstr."\n";
+       }
+       $me->hello();
diff --git a/multiple-attachments.patch b/multiple-attachments.patch
new file mode 100644 (file)
index 0000000..0d0d043
--- /dev/null
@@ -0,0 +1,18 @@
+Description: fix error attaching multiple files
+Origin: vendor
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=63538
+Bug-Ubuntu: https://bugs.launchpad.net/bugs/1657917
+Author: Phil Evans <pae9@star.le.ac.uk>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2017-01-26
+
+--- a/lib/Net/SMTP/TLS.pm
++++ b/lib/Net/SMTP/TLS.pm
+@@ -366,6 +366,7 @@
+                               return undef;
+                       }
+                       $len -= $w;
++                      $offset += $w;
+               }
+               else
+               {
index 7fb9bf928faa1ae3c58e1166525b4d47cfd34aa7..b183c90e5995495c1c23006f5b71a503beb3f339 100644 (file)
@@ -8,12 +8,14 @@ Summary:      Net::SMTP::TLS - An SMTP client supporting TLS and AUTH
 Summary(pl.UTF-8):     Net::SMTP::TLS - klient SMTP obsługujący TLS i AUTH
 Name:          perl-Net-SMTP-TLS
 Version:       0.12
-Release:       2
+Release:       3
 # same as perl
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
 # Source0-md5: a845eba3670e56a197ecd37f571d153a
+Patch0:                io-socket-ssl.patch
+Patch1:                multiple-attachments.patch
 URL:           http://search.cpan.org/dist/Net-SMTP-TLS/
 BuildRequires: perl-devel >= 1:5.8.0
 BuildRequires: rpm-perlprov >= 4.1-13
@@ -39,6 +41,8 @@ implementuje podzbiór metod udostępnianych przez tamten moduł, ale
 
 %prep
 %setup -q -n %{pdir}-%{pnam}-%{version}
+%patch0 -p1
+%patch1 -p1
 
 %build
 %{__perl} Makefile.PL \
This page took 0.109519 seconds and 4 git commands to generate.