]> git.pld-linux.org Git - packages/perl-Net-SFTP.git/blob - perl-Net-SFTP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-SFTP.git] / perl-Net-SFTP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Net
6 %define         pnam    SFTP
7 Summary:        Net::SFTP - Secure File Transfer Protocol client
8 Summary(pl.UTF-8):      Net::SFTP - klient protokołu SFTP (Secure File Transfer Protocol)
9 Name:           perl-Net-SFTP
10 Version:        0.10
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  8383eb0839178cab8cbfe619b232b8c0
17 URL:            http://search.cpan.org/dist/Net-SFTP/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Net-SSH-Perl >= 1.24
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Net::SFTP is a pure-Perl implementation of the Secure File Transfer
28 Protocol (SFTP) - file transfer built on top of the SSH protocol.
29 Net::SFTP uses Net::SSH::Perl to build a secure, encrypted tunnel
30 through which files can be transferred and managed. It provides a
31 subset of the commands listed in the SSH File Transfer Protocol IETF
32 draft, which can be found at
33 http://www.openssh.com/txt/draft-ietf-secsh-filexfer-00.txt .
34
35 %description -l pl.UTF-8
36 Net::SFTP to czysto perlowa implementacja protokołu SFTP (Secure File
37 Transfer Protocol) - przesyłania plików w oparciu o protokół SSH.
38 Net::SFTP używa Net::SSH::Perl do utworzenia bezpiecznego,
39 szyfrowanego tunelu, przez który można przesyłać pliki i zarządzać
40 nimi. Udostępnia podzbiór poleceń podanych w szkicu IETF "SSH File
41 Transfer Protocol", dostępnym pod adresem
42 http://www.openssh.com/txt/draft-ietf-secsh-filexfer-00.txt .
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README ToDo
69 %{perl_vendorlib}/%{pdir}/*.pm
70 %{perl_vendorlib}/%{pdir}/%{pnam}
71 %{_mandir}/man3/*
72 %{_examplesdir}/%{name}-%{version}
This page took 0.0679 seconds and 3 git commands to generate.