]> git.pld-linux.org Git - packages/perl-Net-SCP-Expect.git/blob - perl-Net-SCP-Expect.spec
- new
[packages/perl-Net-SCP-Expect.git] / perl-Net-SCP-Expect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    SCP-Expect
8 Summary:        Net::SCP::Expect - Wrapper for scp that allows passwords via Expect.
9 #Summary(pl):   
10 Name:           perl-Net-SCP-Expect
11 Version:        0.10
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  272080e0abdcf7e8b70cb61f51d05a35
18 BuildRequires:  perl-devel >= 5.6
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Expect >= 1.14
22 BuildRequires:  perl-Term-ReadPassword >= 0.01
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is simply a wrapper around the scp call.  The primary
29 difference between this module and I<Net::SCP> is that you may send
30 a password programmatically, instead of being forced to deal with
31 interactive sessions.
32
33 # %description -l pl
34 # TODO
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make}
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc CHANGES
58 %{perl_vendorlib}/%{pdir}/*/*.pm
59 %{_mandir}/man3/*
This page took 0.027823 seconds and 4 git commands to generate.