]> git.pld-linux.org Git - packages/perl-Net-SCP-Expect.git/blob - perl-Net-SCP-Expect.spec
- tabs in preamble
[packages/perl-Net-SCP-Expect.git] / perl-Net-SCP-Expect.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    SCP-Expect
8 Summary:        Net::SCP::Expect - Wrapper for scp that allows passwords via Expect
9 Summary(pl.UTF-8):      Net::SCP::Expect - wrapper dla scp umożliwiający podawanie haseł przez Expect
10 Name:           perl-Net-SCP-Expect
11 Version:        0.12
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ed57459ab1511bed85479bdcb18cc67a
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Expect >= 1.14
22 BuildRequires:  perl-Term-ReadPassword >= 0.01
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module is simply a wrapper around the scp call. The primary
29 difference between this module and Net::SCP is that you may send
30 a password programmatically, instead of being forced to deal with
31 interactive sessions.
32
33 %description -l pl.UTF-8
34 Ten moduł jest prostym wrapperem dla wywołań scp. Główna różnica
35 między tym modułem a Net::SCP jest taka, że można programowo wysłać
36 hasło zamiast być zmuszonym do obsługi interaktywnych sesji.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES
60 %{perl_vendorlib}/Net/*/*.pm
61 %{_mandir}/man3/*
This page took 0.151285 seconds and 4 git commands to generate.