]> git.pld-linux.org Git - packages/perl-Net-Pcap.git/blob - perl-Net-Pcap.spec
- export PERL_SIGNALS_SAFE and PERL_SIGNALS_UNSAFE symbols
[packages/perl-Net-Pcap.git] / perl-Net-Pcap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (require root privilleges)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    Pcap
8 Summary:        Net::Pcap - Perl binding to the LBL pcap(3) packet capture library
9 Summary(pl.UTF-8):      Net::Pcap - dowiązanie Perla do biblioteki przechwytywania pakietów LBL pcap(3)
10 Name:           perl-Net-Pcap
11 Version:        0.18
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  18d7298dca72b53271d68646c34b6a39
18 Patch0:         libpcap-1.9.patch
19 Patch1:         %{name}-signals-const.patch
20 URL:            http://search.cpan.org/dist/Net-Pcap/
21 BuildRequires:  libpcap-devel >= 1.9.0
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Net::Pcap module is a Perl binding to the LBL pcap(3) packet
28 capture library.
29
30 %description -l pl.UTF-8
31 Moduł Net::Pcap jest dowiązaniem Perla do biblioteki przechwytywania
32 pakietów LBL pcap(3).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36 %patch0 -p1
37 %patch1 -p1
38
39 %build
40 %{__perl} Makefile.PL \
41         CCFLAGS="%{rpmcflags} -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64" \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53 find $RPM_BUILD_ROOT -name .packlist | xargs -r rm -f
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %attr(755,root,root) %{_bindir}/pcapinfo
62 %{perl_vendorarch}/Net/Pcap.pm
63 %dir %{perl_vendorarch}/auto/Net/Pcap
64 %attr(755,root,root) %{perl_vendorarch}/auto/Net/Pcap/Pcap.so
65 %{_mandir}/man1/pcapinfo.1p*
66 %{_mandir}/man3/Net::Pcap.3pm*
This page took 0.114506 seconds and 3 git commands to generate.