]> git.pld-linux.org Git - packages/perl-Net-Jabber.git/blob - perl-Net-Jabber.spec
- rel. 2
[packages/perl-Net-Jabber.git] / perl-Net-Jabber.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses network!)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    Jabber
8 Summary:        Net::Jabber Perl module - access to the Jabber protocol
9 Summary(pl):    Modu³ Perla Net::Jabber - dostêp do protoko³u Jabbera
10 Name:           perl-Net-Jabber
11 Version:        1.30
12 Release:        2
13 License:        LGPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  450ac1976c9b9401689227eb75555abe
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  perl-Digest-SHA1 >= 1.02
19 BuildRequires:  perl-XML-Stream >= 1.17
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Net::Jabber is a collection of Perl modules that provide a Perl
26 Developer access to the Jabber protocol. Using OOP modules they
27 provide a clean interface to writing anything from a full client to a
28 simple protocol tester.
29
30 %description -l pl
31 Net::Jabber to zbiór modu³ów Perla daj±cych programi¶cie perlowemu
32 dostêp do protoko³u Jabbera. Zorientowane obiektowo modu³y daj± czysty
33 interfejs do pisania wszystkiego od pe³nego klienta do prostego
34 testera protoko³u.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38 %{__perl} -pi -e 's/^(use 5.006_)0(01;)(.*)$/$1$2$3/' Jabber/X.pm
39
40 %build
41 echo -e "y\ny\ny\n" | perl Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}
50
51 %{__make} install \
52         UNINST=0 \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README CHANGES
61 %{perl_vendorlib}/Net/*
62 %{_mandir}/man3/*
This page took 0.102744 seconds and 3 git commands to generate.