]> git.pld-linux.org Git - packages/perl-Net-IP.git/blob - perl-Net-IP.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Net-IP.git] / perl-Net-IP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Net
6 %define         pnam    IP
7 Summary:        Net::IP - Perl extension for manipulating IPv4/IPv6 addresses
8 Summary(pl.UTF-8):      Net::IP - rozszerzenie Perla służące do manipulacji adresami IPv4/IPv6
9 Name:           perl-Net-IP
10 Version:        1.26
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3a98e3ac45d69ea38a63a7e678bd716d
17 Patch0:         %{name}-interpreter-path.patch
18 URL:            http://search.cpan.org/dist/Net-IP/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Net::IP Perl module provides functions to deal with IPv4/IPv6
26 addresses. The module can be used as a class, allowing the user to
27 instantiate IP objects, which can be single IP addresses, prefixes, or
28 ranges of addresses. There is also a procedural way of accessing most
29 of the functions. Most subroutines can take either IPv4 or IPv6
30 addresses transparently.
31
32 %description -l pl.UTF-8
33 Moduł Perla Net::IP zawiera funkcje operujące na adresach IPv4/IPv6.
34 Modułu tego można używać jako klasy umożliwiającej użytkownikowi
35 tworzenie obiektów IP, którymi mogą być pojedyncze adresy, prefiksy,
36 czy też zakresy adresów. Dostęp do większości funkcji możliwy jest
37 również drogą proceduralną. Większość procedur może w sposób
38 przezroczysty operować zarówno na adresach IPv4, jak i IPv6.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42 %patch0 -p1
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make}
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT%{_bindir}
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 install ipcount $RPM_BUILD_ROOT%{_bindir}
60 install iptab $RPM_BUILD_ROOT%{_bindir}
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorlib}/Net/IP.pm
69 %attr(755,root,root) %{_bindir}/*
70 %{_mandir}/man3/*
This page took 0.110932 seconds and 4 git commands to generate.