]> git.pld-linux.org Git - packages/perl-Net-HTTP.git/blob - perl-Net-HTTP.spec
up to 6.23
[packages/perl-Net-HTTP.git] / perl-Net-HTTP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests
4 #
5 %define         pdir    Net
6 %define         pnam    HTTP
7 Summary:        Net::HTTP - Low-level HTTP connection (client)
8 Summary(pl.UTF-8):      Net::HTTP - nieskopoziomowe połączenie HTTP (klient)
9 Name:           perl-Net-HTTP
10 Version:        6.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  1682735ddd1c059864ca5c1bbf15ab95
17 URL:            https://metacpan.org/release/Net-HTTP
18 BuildRequires:  perl-devel >= 1:5.8.8
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-IO-Compress
23 BuildRequires:  perl-Test-Simple
24 BuildRequires:  perl-URI
25 %endif
26 Suggests:       perl-IO-Socket-SSL >= 2.012
27 Conflicts:      perl-libwww < 6
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 The Net::HTTP class is a low-level HTTP client. An instance of the
33 Net::HTTP class represents a connection to an HTTP server. The HTTP
34 protocol is described in RFC 2616. The Net::HTTP class supports
35 HTTP/1.0 and HTTP/1.1.
36
37 %description -l pl.UTF-8
38 Klasa Net::HTTP jest niskopoziomowym klientem HTTP. Instancja tej
39 klasy reprezentuje połączenie z serwerem HTTP. Protokół HTTP jest
40 opisany w RFC 2616. Klasa Net::HTTP obsługuje HTTP/1.0 i HTTP/1.1.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %{?with_tests:%{__make} test}
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54
55 %{__make} pure_install \
56         DESTDIR=$RPM_BUILD_ROOT
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc CONTRIBUTORS Changes
64 %{perl_vendorlib}/Net/HTTP.pm
65 %{perl_vendorlib}/Net/HTTPS.pm
66 %{perl_vendorlib}/Net/HTTP
67 %{_mandir}/man3/Net::HTTP*.3pm*
This page took 0.093743 seconds and 4 git commands to generate.