]> git.pld-linux.org Git - packages/perl-Net-DNS.git/blob - perl-Net-DNS.spec
- massive cleaning
[packages/perl-Net-DNS.git] / perl-Net-DNS.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    DNS
8 Summary:        Net::DNS - Perl interface to the DNS resolver
9 Summary(pl):    Net::DNS - interfejs do resolvera DNS
10 Name:           perl-Net-DNS
11 Version:        0.31
12 Release:        1
13 License:        GPL/Artistic
14 Group:          Development/Languages/Perl
15 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 BuildRequires:  perl >= 5.6
17 %if %{?_without_tests:0}%{!?_without_tests:1}
18 BuildRequires:  perl-Digest-MD5 >= 2.12
19 BuildRequires:  perl-Digest-HMAC >= 1.00
20 BuildRequires:  perl-MIME-Base64 >= 2.11
21 BuildRequires:  perl-Test-Simple >= 0.18
22 %endif
23 BuildRequires:  rpm-perlprov >= 3.0.3-16
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Net::DNS is a DNS resolver implemented in Perl.  It allows the programmer
29 to perform nearly any type of DNS query from a Perl script.
30
31 %description -l pl
32 Net::DNS jest resolverem DNS, zaimplementowanym w Perlu.  Pozwala
33 programi¶cie na wykonanie niemal ka¿dego typu zapytania DNS ze skryptu
34 Perla.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 perl Makefile.PL
41 %{__make}
42
43 %{!?_without_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48
49 %{__make} install DESTDIR=$RPM_BUILD_ROOT
50
51 install demo/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
52 cp -a contrib $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README TODO
60 %{perl_sitelib}/Net/DNS.pm
61 %{perl_sitelib}/Net/DNS
62 %{_mandir}/man3/*
63 %{_examplesdir}/%{name}-%{version}
This page took 0.047884 seconds and 3 git commands to generate.