]> git.pld-linux.org Git - packages/perl-Net-DBus.git/blob - perl-Net-DBus.spec
- use __rm macro
[packages/perl-Net-DBus.git] / perl-Net-DBus.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    DBus
8 Summary:        Net::DBus - Perl extension for the DBus message system 
9 Summary(pl.UTF-8):      Net::DBus - Rozszerzenie Perla dla systemu komunikacji DBus
10 Name:           perl-Net-DBus
11 Version:        1.0.0
12 Release:        1
13 # "same as perl", but GPL v2+ is specified
14 License:        GPL v2+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  b17e32976d1a3b56feb908ebd7fed7f1
18 URL:            http://search.cpan.org/dist/Net-DBus/
19 BuildRequires:  dbus-devel >= 0.90
20 BuildRequires:  perl-Time-HiRes
21 BuildRequires:  perl-XML-Parser
22 BuildRequires:  perl-XML-Twig
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpm-perlprov >= 4.1-13
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 Net::DBus provides a Perl XS API to the dbus inter-application
30 messaging system. The Perl API covers the core base level of the dbus
31 APIs, not concerning itself yet with the GLib or Qt wrappers. For more
32 information on dbus visit the project website at
33 <http://www.freedesktop.org/software/dbus/>.
34
35 %description -l pl.UTF-8
36 Moduł Net::DBus dostarcza API Perla XS dla dbusa - systemu komunikacji
37 między aplikacjami. API Perla pokrywa kluczową funkcjonalność API
38 dbusa, nie kłopocząc się jeszcze wrapperami GLiba albo Qt. Więcej
39 informacji na temat dbusa można znaleźć na stronie projektu:
40 <http://www.freedesktop.org/software/dbus/>.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} pure_install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DBus/*.pod
61 %{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DBus/Tutorial
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc AUTHORS CHANGES README
69 %{perl_vendorarch}/Net/DBus.pm
70 %dir %{perl_vendorarch}/Net/DBus
71 %{perl_vendorarch}/Net/DBus/*.pm
72 %dir %{perl_vendorarch}/Net/DBus/Binding
73 %{perl_vendorarch}/Net/DBus/Binding/*.pm
74 %dir %{perl_vendorarch}/Net/DBus/Binding/Message
75 %{perl_vendorarch}/Net/DBus/Binding/Message/*.pm
76 %dir %{perl_vendorarch}/Net/DBus/Test
77 %{perl_vendorarch}/Net/DBus/Test/*.pm
78 %dir %{perl_vendorarch}/auto/Net/DBus
79 %{perl_vendorarch}/auto/Net/DBus/DBus.bs
80 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DBus/DBus.so
81 %{_mandir}/man3/Net::DBus*.3pm*
This page took 0.078568 seconds and 3 git commands to generate.