]> git.pld-linux.org Git - packages/perl-Net-DBus.git/blob - perl-Net-DBus.spec
5c128e7a5aa3c8fd328eaa50324b39090617c216
[packages/perl-Net-DBus.git] / perl-Net-DBus.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Net
7 %define         pnam    DBus
8 Summary:        Net::DBus - Perl extension for the DBus message system 
9 Summary(pl.UTF-8):      Net::DBus - Rozszerzenie Perla dla systemu komunikacji DBus
10 Name:           perl-Net-DBus
11 Version:        1.1.0
12 Release:        2
13 # "same as perl", but GPL v2+ is specified
14 License:        GPL v2+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Net/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  da44a16f8abf1db76f5ccf50d9926944
18 URL:            http://search.cpan.org/dist/Net-DBus/
19 BuildRequires:  dbus-devel >= 1.3.0
20 BuildRequires:  perl-Time-HiRes
21 BuildRequires:  perl-XML-Twig
22 BuildRequires:  perl-devel >= 1:5.8.0
23 %if %{with tests}
24 BuildRequires:  perl(Test::CPAN::Changes)
25 BuildRequires:  perl-Test-Pod
26 BuildRequires:  perl-Test-Pod-Coverage
27 BuildRequires:  perl-Test-Simple
28 %endif
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 Requires:       dbus-libs >= 1.3.0
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Net::DBus provides a Perl XS API to the dbus inter-application
36 messaging system. The Perl API covers the core base level of the dbus
37 APIs, not concerning itself yet with the GLib or Qt wrappers. For more
38 information on dbus visit the project website at
39 <http://www.freedesktop.org/software/dbus/>.
40
41 %description -l pl.UTF-8
42 Moduł Net::DBus dostarcza API Perla XS dla dbusa - systemu komunikacji
43 między aplikacjami. API Perla pokrywa kluczową funkcjonalność API
44 dbusa, nie kłopocząc się jeszcze wrapperami GLiba albo Qt. Więcej
45 informacji na temat dbusa można znaleźć na stronie projektu:
46 <http://www.freedesktop.org/software/dbus/>.
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DBus/*.pod
67 %{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/Net/DBus/Tutorial
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc AUTHORS Changes README
75 %{perl_vendorarch}/Net/DBus.pm
76 %dir %{perl_vendorarch}/Net/DBus
77 %{perl_vendorarch}/Net/DBus/*.pm
78 %dir %{perl_vendorarch}/Net/DBus/Binding
79 %{perl_vendorarch}/Net/DBus/Binding/*.pm
80 %dir %{perl_vendorarch}/Net/DBus/Binding/Message
81 %{perl_vendorarch}/Net/DBus/Binding/Message/*.pm
82 %dir %{perl_vendorarch}/Net/DBus/Test
83 %{perl_vendorarch}/Net/DBus/Test/*.pm
84 %dir %{perl_vendorarch}/auto/Net/DBus
85 %attr(755,root,root) %{perl_vendorarch}/auto/Net/DBus/DBus.so
86 %{_mandir}/man3/Net::DBus*.3pm*
This page took 0.10916 seconds and 3 git commands to generate.