]> git.pld-linux.org Git - packages/perl-Net-BGP.git/blob - perl-Net-BGP.spec
- license fixes, cosmetics
[packages/perl-Net-BGP.git] / perl-Net-BGP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    BGP
8 Summary:        Net::BGP - Border Gateway Protocol version 4 speaker/listener library
9 Summary(pl):    Net::BGP - biblioteka obs³uguj±ca Border Gateway Protocol w wersji 4
10 Name:           perl-Net-BGP
11 Version:        0.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  65d8da8512f9b886aa85d6422eaec874
18 %if %{with tests}
19 BuildRequires:  perl(List::Util) >= 1.01
20 BuildRequires:  perl-Test-Harness >= 2.00
21 BuildRequires:  perl-Test-Simple >= 0.47
22 %endif
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module is an implementation of the BGP-4 inter-domain routing
30 protocol. It encapsulates all of the functionality needed to establish
31 and maintain a BGP peering session and exchange routing update
32 information with the peer. It aims to provide a simple API to the BGP
33 protocol for the purposes of automation, logging, monitoring, testing,
34 and similar tasks using the power and flexibility of Perl. The module
35 does not implement the functionality of a RIB (Routing Information
36 Base) nor does it modify the kernel routing table of the host system.
37 However, such operations could be implemented using the API provided
38 by the module.
39
40 %description -l pl
41 Ten modu³ jest implementacj± protoko³u routingu miêdzydomenowego
42 BGP-4. Zawiera on ca³± funkcjonalno¶æ potrzebn± do ustanowienia i
43 zarz±dzania sesj± BGP oraz wymiany informacji o uaktualnieniach
44 routingu z drug± stron±. Celem jest dostarczenie prostego API do
45 protoko³u BGP do celów automatyzacji, logowania, monitorowania,
46 testowania i podobnych zadañ z u¿yciem potêgi i elastyczno¶ci Perla.
47 Modu³ nie zawiera implementacji RIB (Routing Information Base) ani
48 nie modyfikuje tablicy routingu w j±drze systemu, jednak takie
49 operacje mog± byæ zaimplementowane przy u¿yciu API dostarczonego
50 przez ten modu³.
51
52 %prep
53 %setup -q -n %{pdir}-%{pnam}-%{version}
54
55 %build
56 %{__perl} Makefile.PL \
57         INSTALLDIRS=vendor
58 %{__make}
59
60 %{?with_tests:%{__make} test}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc Changes README
74 %{perl_vendorlib}/Net/BGP.pm
75 %{perl_vendorlib}/Net/BGP
76 %{_mandir}/man3/*
This page took 0.063474 seconds and 4 git commands to generate.