]> git.pld-linux.org Git - packages/perl-Net-ARP.git/blob - perl-Net-ARP.spec
- up to 0.5
[packages/perl-Net-ARP.git] / perl-Net-ARP.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires uid 0)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Net
7 %define pnam    ARP
8 Summary:        Perl extension for creating ARP packets
9 Summary(pl):    Rozszerzenie Perla do tworzenia pakietów ARP
10 Name:           perl-Net-ARP
11 Version:        0.5
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tgz
17 # Source0-md5:  751aba46341312664ab63450a0fe549a
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Net-Pcap
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module can be used to create and send ARP packets and to get the
27 MAC address of an ethernet interface or IP address.
28
29 %description -l pl
30 Ten modu³ mo¿e byæ u¿yty do stworzenia i wys³ania pakietów ARP oraz do
31 pobrania adresu MAC interfejsu sieciowego lub adresu IP.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/Net/*.pm
57 %dir %{perl_vendorarch}/auto/Net/ARP
58 %{perl_vendorarch}/auto/Net/ARP/ARP.bs
59 %attr(755,root,root) %{perl_vendorarch}/auto/Net/ARP/ARP.so
60 %{_mandir}/man3/*
This page took 0.086676 seconds and 4 git commands to generate.