]> git.pld-linux.org Git - packages/perl-Nagios-Object.git/blob - perl-Nagios-Object.spec
d5ce2a5c5cae0e1b6058e047c928ab1c767d6cb9
[packages/perl-Nagios-Object.git] / perl-Nagios-Object.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Nagios
7 %define         pnam    Object
8 Summary:        Nagios::Object - Perl objects to represent Nagios objects
9 Summary(pl.UTF-8):      Nagios::Object - obiekty Perla reprezentujące obiekty Nagiosa
10 Name:           perl-Nagios-Object
11 Version:        0.21.3
12 Release:        1
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/D/DU/DUNCS/Nagios-Object-%{version}.tar.gz
16 # Source0-md5:  1b64bd73b045e9e111bc0755f0c692a0
17 URL:            http://search.cpan.org/dist/Nagios-Object/
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with autodeps} || %{with tests}
22 BuildRequires:  perl-Test-Exception
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module contains the code for creating Perl objects to represent
29 any of the Nagios objects. All of the Perl classes are auto-generated
30 at compile-time, so it's pretty trivial to add new attributes or even
31 entire objects.
32
33 %description -l pl.UTF-8
34 Ten moduł zawiera kod do tworzenia obiektów Perla reprezentujących
35 dowolne obiekty Nagiosa. Wszystkie klasy Perla są generowane
36 automatycznie w czasie kompilacji, więc łatwo dodawać nowe atrybuty
37 czy nawet całe obiekty.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Build.PL \
44         installdirs=vendor \
45         destdir=$RPM_BUILD_ROOT
46 ./Build
47
48 %{?with_tests:./Build test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 ./Build install
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 mv $RPM_BUILD_ROOT{%{_bindir}/*,%{_examplesdir}/%{name}-%{version}}
56
57 rm -rf $RPM_BUILD_ROOT%{_mandir}/man1
58 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/.packlist
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc ChangeLog README
66 %{perl_vendorlib}/Nagios
67 %{_mandir}/man3/*
68 %{_examplesdir}/%{name}-%{version}
This page took 0.06527 seconds and 3 git commands to generate.