]> git.pld-linux.org Git - packages/perl-MooseX-AttributeHelpers.git/blob - perl-MooseX-AttributeHelpers.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-MooseX-AttributeHelpers.git] / perl-MooseX-AttributeHelpers.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    MooseX
6 %define pnam    AttributeHelpers
7 Summary:        MooseX::AttributeHelpers - Extend your attribute interfaces
8 #Summary(pl.UTF-8):     
9 Name:           perl-MooseX-AttributeHelpers
10 Version:        0.23
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ebdd543a211884854b6c87adf25e6e22
17 URL:            http://search.cpan.org/dist/MooseX-AttributeHelpers/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Moose >= 0.45
22 BuildRequires:  perl-Test-Exception >= 0.21
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 While Moose attributes provide you with a way to name your accessors,
29 readers, writers, clearers and predicates, this library provides commonly
30 used attribute helper methods for more specific types of data.
31
32 As seen in the /SYNOPSIS, you specify the extension via the 
33 metaclass parameter. Available meta classes are:
34
35 # %description -l pl.UTF-8
36 # TODO
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} pure_install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc ChangeLog README
60 %{perl_vendorlib}/MooseX/*.pm
61 %{perl_vendorlib}/MooseX/AttributeHelpers
62 %{_mandir}/man3/*
This page took 0.034659 seconds and 3 git commands to generate.