]> git.pld-linux.org Git - packages/perl-MooseX-AttributeHelpers.git/blob - perl-MooseX-AttributeHelpers.spec
25aa7111772709f121168381933092986f4b1db7
[packages/perl-MooseX-AttributeHelpers.git] / perl-MooseX-AttributeHelpers.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    MooseX
7 %define pnam    AttributeHelpers
8 Summary:        MooseX::AttributeHelpers - Extend your attribute interfaces
9 #Summary(pl.UTF-8):     
10 Name:           perl-MooseX-AttributeHelpers
11 Version:        0.23
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/CPAN/authors/id/D/DR/DROLSKY/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  ebdd543a211884854b6c87adf25e6e22
18 URL:            http://search.cpan.org/dist/MooseX-AttributeHelpers/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Moose >= 0.45
23 BuildRequires:  perl-Test-Exception >= 0.21
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 While Moose attributes provide you with a way to name your accessors,
30 readers, writers, clearers and predicates, this library provides commonly
31 used attribute helper methods for more specific types of data.
32
33 As seen in the /SYNOPSIS, you specify the extension via the 
34 metaclass parameter. Available meta classes are:
35
36 # %description -l pl.UTF-8
37 # TODO
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} pure_install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc ChangeLog README
61 %{perl_vendorlib}/MooseX/*.pm
62 %{perl_vendorlib}/MooseX/AttributeHelpers
63 %{_mandir}/man3/*
This page took 0.042655 seconds and 2 git commands to generate.