]> git.pld-linux.org Git - packages/perl-Moo.git/blob - perl-Moo.spec
- updated to 2.005004
[packages/perl-Moo.git] / perl-Moo.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Moo
6 Summary:        Moo - Minimalist Object Orientation (with Moose compatibility)
7 Summary(pl.UTF-8):      Moo - Minimalist Object Orientation (minimalna obiektowość, zgodna z Moose)
8 Name:           perl-Moo
9 Version:        2.005004
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/H/HA/HAARG/Moo-%{version}.tar.gz
15 # Source0-md5:  49ecf491b49b9b200e8a5dfd1a42b480
16 URL:            https://metacpan.org/release/Moo
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl(Exporter) >= 5.57
22 BuildRequires:  perl-Class-Method-Modifiers >= 2.11
23 BuildRequires:  perl-Devel-GlobalDestruction >= 0.11
24 BuildRequires:  perl-Module-Runtime >= 0.014
25 BuildRequires:  perl-Role-Tiny >= 2.002003
26 BuildRequires:  perl-Scalar-List-Utils >= 1.00
27 BuildRequires:  perl-Sub-Quote >= 2.006006
28 BuildRequires:  perl-Test-Fatal >= 0.003
29 BuildRequires:  perl-Test-Simple >= 0.94
30 BuildRequires:  perl-strictures >= 2
31 %endif
32 Requires:       perl-Devel-GlobalDestruction >= 0.11
33 Requires:       perl-Module-Runtime >= 0.014
34 Requires:       perl-Role-Tiny >= 2.002003
35 Requires:       perl-Scalar-List-Utils >= 1.00
36 Requires:       perl-Sub-Quote >= 2.006006
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 This module is an extremely light-weight subset of Moose optimised for
42 rapid startup and "pay only for what you use".
43
44 It also avoids depending on any XS modules to allow simple
45 deployments. The name Moo is based on the idea that it provides almost
46 -- but not quite -- two thirds of Moose.
47
48 Unlike Mouse this module does not aim at full compatibility with
49 Moose's surface syntax, preferring instead of provide full
50 interoperability via the metaclass inflation capabilities described in
51 documentation.
52
53 %description -l pl.UTF-8
54 Ten moduł to ekstremalnie lekki podzbiór Moose zoptymalizowany pod
55 kątem szybkiego uruchamiania i "płacenia tylko za to, czego się
56 używa".
57
58 Moduł ten unika także zależności od dowolnych modułów XS, co pozwala
59 na proste wdrożenia. Nazwa Moo opiera się na idei, że moduł ten
60 udostępnia prawie - ale nie dokładnie - dwie trzecie Moose.
61
62 W przeciwieństwie do Moose, celem modułu nie jest zapewnienie pełnej
63 zgodności ze składnią Moose, zamiast tego zapewniona jest pełna
64 interoperacyjność poprzez możliwości inflacji metaklasy, opisane w
65 dokumentacji.
66
67 %prep
68 %setup -q -n %{pdir}-%{version}
69
70 %build
71 %{__perl} Makefile.PL \
72         INSTALLDIRS=vendor
73 %{__make}
74
75 %{?with_tests:%{__make} test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} pure_install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README
89 %dir %{perl_vendorlib}/Method
90 %dir %{perl_vendorlib}/Method/Generate
91 %{perl_vendorlib}/Method/Generate/Accessor.pm
92 %{perl_vendorlib}/Method/Generate/BuildAll.pm
93 %{perl_vendorlib}/Method/Generate/Constructor.pm
94 %{perl_vendorlib}/Method/Generate/DemolishAll.pm
95 %{perl_vendorlib}/Moo.pm
96 %{perl_vendorlib}/Moo
97 %{perl_vendorlib}/oo.pm
98 %{_mandir}/man3/Moo.3pm*
99 %{_mandir}/man3/Moo::Role.3pm*
100 %{_mandir}/man3/oo.3pm*
This page took 0.19597 seconds and 4 git commands to generate.