]> git.pld-linux.org Git - packages/perl-Module-Pluggable.git/blob - perl-Module-Pluggable.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-Module-Pluggable.git] / perl-Module-Pluggable.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Module
6 %define         pnam    Pluggable
7 Summary:        Automatically give your module the ability to have plugins
8 Summary(pl.UTF-8):      Automatyczne umożliwianie modułom posiadania wtyczek
9 Name:           perl-Module-Pluggable
10 Version:        5.2
11 Release:        1
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Module/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  87ce2971662efd0b69a81bb4dc9ea76c
16 URL:            http://search.cpan.org/dist/Module-Pluggable/
17 BuildRequires:  perl-Class-Inspector
18 BuildRequires:  perl-Module-Build >= 0.38
19 %{?with_tests:BuildRequires:    perl-Test-Simple >= 0.62}
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 Requires:       perl-Module-Runtime >= 0.012
22 Requires:       perl-dirs >= 1.0-5
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Provides a simple but, hopefully, extensible way of having 'plugins'
28 for your module. Obviously this isn't going to be the be all and end
29 all of solutions but it works for me.
30
31 Essentially all it does is export a method into your namespace that
32 looks through a search path for .pm files and turn those into class
33 names. Optionally it instantiates those classes for you.
34
35 %description -l pl.UTF-8
36 Ten moduł dostarcza prosty, ale rozszerzalny sposób posiadania
37 "wtyczek" dla własnego modułu. Oczywiście nie jest to pełne i końcowe
38 rozwiązanie, ale autorowi działa.
39
40 Zasadniczo wszystko co robi ten moduł to wyeksportowanie metody
41 przeszukującej ścieżkę pod kątem plików .pm i zamieniającej je na
42 nazwy klas. Opcjonalnie może dziedziczyć te klasy.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes
67 %{perl_vendorlib}/Devel/InnerPackage.pm
68 %{perl_vendorlib}/Module/Pluggable.pm
69 %dir %{perl_vendorlib}/Module
70 %dir %{perl_vendorlib}/Module/Pluggable
71 %{perl_vendorlib}/Module/Pluggable/Object.pm
72 %{_mandir}/man3/Devel::InnerPackage.3pm*
73 %{_mandir}/man3/Module::Pluggable*.3pm*
This page took 0.134272 seconds and 4 git commands to generate.